Bug 1017711 - Missing dependencies in maven repo distribution
Missing dependencies in maven repo distribution
Status: CLOSED DUPLICATE of bug 1032592
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER3
: 6.2.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks: 1010419
  Show dependency treegraph
 
Reported: 2013-10-10 07:25 EDT by Jiri Holusa
Modified: 2014-04-28 11:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 10:02:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Holusa 2013-10-10 07:25:16 EDT
When testing jdg quickstarts with maven repo zip distribution found out that following dependencies are missing in the .zip:

org.infinispan:infinispan-bom:pom:6.0.0.CR1-redhat-2
org.jboss.weld.servlet:weld-servlet:jar:1.1.13.Final-redhat-1
Comment 3 Tristan Tarrant 2013-10-18 07:19:24 EDT
Fixed in ER3.1
Comment 4 Jiri Holusa 2013-10-21 04:06:05 EDT
Found another missing dependency:

org.jboss.component.management:jboss-dependency-management-all:pom:6.1.1.Final-redhat-61

The whole error message I get from packaging jdg quickstarts is:

Failed to execute goal on project jboss-carmart: Could not resolve dependencies for project org.jboss.quickstarts.jdg:jboss-carmart:war:6.2.0.ER3.1-redhat-1: Failed to collect dependencies at org.infinispan:infinispan-core:jar:6.0.0.CR1-redhat-3: Failed to read artifact descriptor for org.infinispan:infinispan-core:jar:6.0.0.CR1-redhat-3: Could not find artifact org.jboss.component.management:jboss-dependency-management-all:pom:6.1.1.Final-redhat-61 in redhat-earlyaccess-repository-group (http://maven.repository.redhat.com/earlyaccess/all/)
Comment 5 Jiri Holusa 2013-10-21 04:39:40 EDT
I manually added the previous dependency and found another missing one:

org.jboss.component.management:jboss-project-dependency-relocations:pom:6.1.1.Final-redhat-61
Comment 6 Jiri Holusa 2013-10-21 06:27:37 EDT
Going deeper and found another missing dependencies:

org.apache.maven.plugins:maven-enforcer-plugin:1.0-redhat-1
org.apache.maven.plugins:maven-source-plugin:2.1.2-redhat-1
org.apache.maven.plugins:maven-clean-plugin:jar:2.4.1-redhat-1
Comment 7 Jiri Holusa 2013-10-21 09:21:42 EDT
Found another missing dependency, unfortunately I'm stuck at it because I don't know how to resolve it.

Failed to execute goal org.codehaus.mojo:buildnumber-maven-plugin:1.0-redhat-1:create (get-scm-revision) on project jboss-jdg-quickstarts: Execution get-scm-revision of goal org.codehaus.mojo:buildnumber-maven-plugin:1.0-redhat-1:create failed: A required class was missing while executing org.codehaus.mojo:buildnumber-maven-plugin:1.0-redhat-1:create: org/apache/maven/scm/ScmException
Comment 8 Jiri Holusa 2013-11-21 06:39:18 EST
Hi, 
this issue occured again with new JDG_6.2.0.ER4. I'm trying to run jdg quickstarts, specifically carmart-tx. It gives me missing artifact:

org.jboss.jbossts:jbossjta:jar:4.17.7.Final-redhat-4
Comment 9 Jiri Holusa 2013-12-03 10:02:24 EST
This is very similiar to https://bugzilla.redhat.com/show_bug.cgi?id=1032592

So moving there.

*** This bug has been marked as a duplicate of bug 1032592 ***

Note You need to log in before you can comment on or make changes to this bug.