Bug 1017742 - [rhevh] upgrade from Admin portal failed - upgrade: java.io.IOException: Command returned failure code 1 during SSH session
[rhevh] upgrade from Admin portal failed - upgrade: java.io.IOException: Comm...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Fabian Deutsch
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 08:28 EDT by Jiri Belka
Modified: 2016-02-10 14:20 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 07:42:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (14.01 MB, application/x-tar)
2013-10-10 08:48 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-10-10 08:28:05 EDT
Description of problem:
	
2013-Oct-10, 14:04
Host dell-r210ii-13 installation failed. Upgrade failed, please refer to logs for further information.
	
2013-Oct-10, 14:04
Failed to install Host dell-r210ii-13. Step: RHEV_INSTALL.

Version-Release number of selected component (if applicable):
is18
RHEV Hypervisor - 6.5 - 20130918.0.el6 -> rhevh-6.5-20131009.0.el6ev.iso

How reproducible:
100%

Steps to Reproduce:
1. upgrade from Admin Portal
2.
3.

Actual results:
failed (not obvious where...)

Expected results:


Additional info:
Comment 1 Jiri Belka 2013-10-10 08:48:10 EDT
Created attachment 810503 [details]
logs
Comment 2 Fabian Deutsch 2013-10-21 10:18:30 EDT
I took this line from the engine log:
2013-10-10 11:10:03,838 ERROR [org.ovirt.engine.core.utils.ssh.SSHDialog] (pool-5-thread-50) SSH error running command root@10.34.62.205:'/usr/share/vdsm-reg/vdsm-upgrade': java.io.IOException: Command returned failure code 1 during SSH session 'root@10.34.62.205'

'/usr/share/vdsm-reg/vdsm-upgrade' is having a problem.

From the host log I can also see that '/usr/libexec/ovirt-functions get_live_disk' is beeing called, but I can't see any logged return value or stdout which makes it hard to see if there are problems there too.

At least vds-upgrade fails with:
Thu, 10 Oct 2013 12:04:41 ERROR    <BSTRAP component='RHEV_INSTALL' status='FAIL'/>

Re-assigning this bug to vdsm.
Comment 3 Douglas Schilling Landgraf 2013-10-21 17:32:58 EDT
Hi Fabian,

(In reply to Fabian Deutsch from comment #2)
> I took this line from the engine log:
> 2013-10-10 11:10:03,838 ERROR [org.ovirt.engine.core.utils.ssh.SSHDialog]
> (pool-5-thread-50) SSH error running command
> root@10.34.62.205:'/usr/share/vdsm-reg/vdsm-upgrade': java.io.IOException:
> Command returned failure code 1 during SSH session 'root@10.34.62.205'
> 
> '/usr/share/vdsm-reg/vdsm-upgrade' is having a problem.
> 
> From the host log I can also see that '/usr/libexec/ovirt-functions
> get_live_disk' is beeing called, but I can't see any logged return value or
> stdout which makes it hard to see if there are problems there too.
> 
> At least vds-upgrade fails with:
> Thu, 10 Oct 2013 12:04:41 ERROR    <BSTRAP component='RHEV_INSTALL'
> status='FAIL'/>
> 
> Re-assigning this bug to vdsm.

I can see from strace:

# strace -f -s255 python /usr/share/vdsm-reg/vdsm-upgrade 

Process 17279 detached
<... wait4 resumed> [{WIFEXITED(s) && WEXITSTATUS(s) == 1}], 0, NULL) = 17279
--- SIGCHLD (Child exited) @ 0 (0) ---
gettimeofday({1382390159, 415566}, NULL) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=118, ...}) = 0
write(5, "2013-10-21 21:15:59,415 - DEBUG - ovirtfunctions - cp -p /live/isolinux/version /liveos\n", 88) = 88
gettimeofday({1382390159, 417957}, NULL) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=118, ...}) = 0
write(5, "2013-10-21 21:15:59,417 - DEBUG - ovirtfunctions - \n", 52) = 52
gettimeofday({1382390159, 418489}, NULL) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=118, ...}) = 0
write(5, "2013-10-21 21:15:59,418 - ERROR - install - version details copy failed.\n", 73) = 73


^^^ here stdout

stat("/dev/mapper/1ATA_QEMU_HARDDISK_QM00001p2", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 2), ...}) = 0
stat("/dev/mapper/1ATA_QEMU_HARDDISK_QM00001p", 0x7fff41c5b6c0) = -1 ENOENT (No such file or directory)
stat("/dev/mapper/1ATA_QEMU_HARDDISK_QM00001", {st_mode=S_IFBLK|0660, st_rdev=makedev(253, 0), ...}) = 0
lstat("/live", {st_mode=S_IFDIR|0555, st_size=2048, ...}) = 0
lstat("/live", {st_mode=S_IFDIR|0555, st_size=2048, ...}) = 0
lstat("/live/..", {st_mode=S_IFDIR|0555, st_size=4096, ...}) = 0
open("/live/isolinux/version", O_RDONLY) = -1 ENOENT (No such file or directory)

^^ Another point


Looks like ovirt-node component, moving back. Please let me know if I can help anything else here.
Comment 5 Jiri Belka 2013-11-04 05:28:42 EST
upgrade from RHEVM ui ok with 6.5-20131029.0.el6ev.
Comment 6 Barak 2013-11-04 08:58:02 EST
According to comment #5 this bug should not be in NEW (at lease POST or even MODIFIED).

Can you please update ?
Comment 7 Fabian Deutsch 2013-12-09 07:42:48 EST
Closing as NOTABUG because it was a build problem.

Note You need to log in before you can comment on or make changes to this bug.