Bug 1017757 - Cannot open designer palette in IE
Cannot open designer palette in IE
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Windows
medium Severity medium
: ER6
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 09:02 EDT by Kris Verlaenen
Modified: 2014-08-06 16:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Verlaenen 2013-10-10 09:02:29 EDT
When clicking on the categories (e.g. start events) in the palette on the left, the categories do not open, so it's impossible to select one of the elements inside.

The java script console shows following error message if I click on the category:
SCRIPT5007: Unable to get property 'ui' of undefined or null reference
ext-all.js, line 100, character 2113.

This is line 100, character 2113 is "A.ui.ecClick(B)".

Ext.tree.TreeEventModel=function(A){this.tree=A;this.tree.on("render",this.initEvents,this)};Ext.tree.TreeEventModel.prototype={initEvents:function(){var A=this.tree.getTreeEl();A.on("click",this.delegateClick,this);if(this.tree.trackMouseOver!==false){A.on("mouseover",this.delegateOver,this);A.on("mouseout",this.delegateOut,this)}A.on("dblclick",this.delegateDblClick,this);A.on("contextmenu",this.delegateContextMenu,this)},getNode:function(B){var A;if(A=B.getTarget(".x-tree-node-el",10)){var C=Ext.fly(A,"_treeEvents").getAttributeNS("ext","tree-node-id");if(C){return this.tree.getNodeById(C)}}return null},getNodeTarget:function(B){var A=B.getTarget(".x-tree-node-icon",1);if(!A){A=B.getTarget(".x-tree-node-el",6)}return A},delegateOut:function(B,A){if(!this.beforeEvent(B)){return }if(B.getTarget(".x-tree-ec-icon",1)){var C=this.getNode(B);this.onIconOut(B,C);if(C==this.lastEcOver){delete this.lastEcOver}}if((A=this.getNodeTarget(B))&&!B.within(A,true)){this.onNodeOut(B,this.getNode(B))}},delegateOver:function(B,A){if(!this.beforeEvent(B)){return }if(this.lastEcOver){this.onIconOut(B,this.lastEcOver);delete this.lastEcOver}if(B.getTarget(".x-tree-ec-icon",1)){this.lastEcOver=this.getNode(B);this.onIconOver(B,this.lastEcOver)}if(A=this.getNodeTarget(B)){this.onNodeOver(B,this.getNode(B))}},delegateClick:function(B,A){if(!this.beforeEvent(B)){return }if(B.getTarget("input[type=checkbox]",1)){this.onCheckboxClick(B,this.getNode(B))}else{if(B.getTarget(".x-tree-ec-icon",1)){this.onIconClick(B,this.getNode(B))}else{if(this.getNodeTarget(B)){this.onNodeClick(B,this.getNode(B))}}}},delegateDblClick:function(B,A){if(this.beforeEvent(B)&&this.getNodeTarget(B)){this.onNodeDblClick(B,this.getNode(B))}},delegateContextMenu:function(B,A){if(this.beforeEvent(B)&&this.getNodeTarget(B)){this.onNodeContextMenu(B,this.getNode(B))}},onNodeClick:function(B,A){A.ui.onClick(B)},onNodeOver:function(B,A){A.ui.onOver(B)},onNodeOut:function(B,A){A.ui.onOut(B)},onIconOver:function(B,A){A.ui.addClass("x-tree-ec-over")},onIconOut:function(B,A){A.ui.removeClass("x-tree-ec-over")},onIconClick:function(B,A){A.ui.ecClick(B)},onCheckboxClick:function(B,A){A.ui.onCheckChange(B)},onNodeDblClick:function(B,A){A.ui.onDblClick(B)},onNodeContextMenu:function(B,A){A.ui.onContextMenu(B)},beforeEvent:function(A){if(this.disabled){A.stopEvent();return false}return true},disable:function(){this.disabled=true},enable:function(){this.disabled=false}};
Comment 2 Kris Verlaenen 2013-10-23 09:20:35 EDT
Since there is a workaround that opens the palette in IE by default (for all categories), lowering the priority of this one.
Comment 3 Marek Baluch 2013-10-31 14:38:54 EDT
From your comment I gathered that all categories are opened by default. What happens if you close it? are you able to reopen it?

(windows testing is blocked at the moment - we are working on it :))
Comment 4 Kris Verlaenen 2013-10-31 15:32:58 EDT
Marek, categories aren't working at all if you click on them.  You couldn't open them but now, when they are open by default, you also cannot close them.
Comment 5 Marek Baluch 2013-11-01 07:18:16 EDT
Ah - I see. Thank you for clarification. That definitely lovers the priority. Possibly also severity. I will lower it too when we get the chance to verify the workaround.
Comment 6 Marek Baluch 2013-12-12 05:52:21 EST
Verified - Palette is available. Lowering severity.
Comment 7 Lukáš Petrovický 2014-01-06 09:45:55 EST
Marek, would you mind closing this issue and possibly opening a feature request for re-introducing collapsible palettes in IE?

We don't want to go back to this issue on every triage.
Comment 8 Marek Baluch 2014-01-06 09:48:06 EST
Sure - sounds reasonable.

Closing as VERIFIED.
Comment 9 Lukáš Petrovický 2014-02-07 11:15:38 EST
This BZ has been part of the 6.0.0 stream.

Note You need to log in before you can comment on or make changes to this bug.