Bug 1017761 - Wrong error message when validating an answer file parameter
Wrong error message when validating an answer file parameter
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.2.5
Assigned To: Alex Lourie
sefi litmanovich
integration
: Triaged, ZStream
Depends On: 916107
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 09:07 EDT by rhev-integ
Modified: 2013-12-18 09:09 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the setup validated a parameter in the answer file in engine-setup it generated an "error reading parameter" message. This was confusing confusing. since reading was successful, validation was the failure. The message has been changed to 'Error: failed validation' for the same case, making it easier to understand the root of the problem.
Story Points: ---
Clone Of: 916107
Environment:
Last Closed: 2013-12-18 09:09:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rhev-integ 2013-10-10 09:07:29 EDT
+++ This bug is a RHEV-M zstream clone. The original bug is: +++
+++   https://bugzilla.redhat.com/show_bug.cgi?id=916107. +++
+++ Requested by "idith@redhat.com" +++
======================================================================



----------------------------------------------------------------------
Following comment by obasan@redhat.com on February 27 at 10:20:16, 2013

Description of problem:
When the setup validates a parameter in the answer file in engine-setup
it throws an "error reading parameter" error.
this is very confusing. since reading was successful. validation is the failure.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.run the engine setup with the --answer-file parameter and supply a parameter that will fail in validation. for example wrong fqdn

  
Actual results:
"Error reading parameter"

Expected results:
should output "failed validating parameter"

----------------------------------------------------------------------
Following comment by alourie@redhat.com on September 29 at 13:57:21, 2013

Andrew

This is not relevant for 3.3, only 3.2.z

What should I do with this bug?

----------------------------------------------------------------------
Following comment by italkohe@redhat.com on October 10 at 11:53:31, 2013

Suggest z-stream flag per Alex's request.

----------------------------------------------------------------------
Following comment by alourie@redhat.com on October 10 at 12:39:13, 2013

Moving to ON_QA to verify that it is not relevant for 3.3

Then it can be cloned to 3.2.z
Comment 2 Charlie 2013-11-27 19:42:14 EST
This bug is currently attached to errata RHBA-2013:16431. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 3 sefi litmanovich 2013-11-28 08:55:56 EST
Verifired on RHEL 6.4, RHEVM 3.2.5 SF22 rhevm-setup-3.2.5-0.48.el6ev.noarch
Comment 5 errata-xmlrpc 2013-12-18 09:09:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1831.html

Note You need to log in before you can comment on or make changes to this bug.