Bug 1017770 - Designer is caching old version of process in IE
Designer is caching old version of process in IE
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Windows
high Severity high
: CR1
: 6.0.0
Assigned To: Tihomir Surdilovic
Tomas Livora
:
: 1049405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 09:29 EDT by Kris Verlaenen
Modified: 2014-08-06 16:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Verlaenen 2013-10-10 09:29:25 EDT
Description of problem:
When editing a process in IE and then closing and reopening designer, it is regularly showing an older, cached version of the process.

How reproducible:


Steps to Reproduce:
1. Open process in designer in IE
2. Edit process, save and close designer
3. Reopen designer

Actual results:
Showing old, cached version of the process

Expected results:
Showing new, updated version of the process

Additional info:
Works fine on Chrome and FF

Workaround:
In IE Setting, under Browsing History Settings, change Temporary Internet Files update policy to check for a new version "Every time I visit the webpage" (not "Automatically" whichis the default.
Comment 1 Kris Verlaenen 2013-10-10 09:32:17 EDT
I believe adding something like the current timestamp as a param in the request might trick IE into believing this is different from the previous cached version and thus always retrieving the latest one.
Comment 3 Tihomir Surdilovic 2013-10-11 12:53:20 EDT
fixed in designer master and 6.0.x branches.
Comment 4 Tomas Livora 2013-12-09 04:24:14 EST
The bug is not fixed in ER5. When I open a process in IE 11, change it, save it, close the designer and reopen it, there is an old version of the process.
Comment 5 Kris Verlaenen 2013-12-09 20:35:11 EST
Tiho, I can confirm this doesn't seem to be fixed in latest 6.0.x.  Are you sure that the fix was cherry-picked (as I'm pretty sure I tested a fix at some point, that seemed to work)?

Workaround:  Turn off caching of webpages in IE
For IE11: Tools -> Internet Options, in the General tab, under browsing history, click Settings button and in the Temporary Internet Files tab, set the Check for newer versions of stored pages to Every time I visit the webpage.
Comment 6 Tihomir Surdilovic 2013-12-10 12:20:29 EST
The original commit was placed in the 6.0.x branch. I have now added the no-cache directive on the designer jsp itself to help prevent caching of it in the browser. Please retest. This fix is in the Designer master and 6.0.x branches.
Comment 7 Kris Verlaenen 2013-12-18 09:16:59 EST
Tiho, testing latest 6.0.x still shows the same behavior.
Comment 8 Kris Verlaenen 2014-01-07 09:46:29 EST
*** Bug 1049405 has been marked as a duplicate of this bug. ***
Comment 9 Tihomir Surdilovic 2014-01-08 14:07:45 EST
fixed in designer master and 6.0.x branches
Comment 10 Tomas Livora 2014-01-20 07:20:18 EST
Verified on BPMS 6.0.0-CR1

Note You need to log in before you can comment on or make changes to this bug.