Bug 1017781 - Completing the DTGov demos - DTGov cannot load required task-form from maven repository
Completing the DTGov demos - DTGov cannot load required task-form from maven ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Kurt T Stam
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 09:41 EDT by Stefan Bunciak
Modified: 2014-03-05 10:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DTGOV-88 Major Closed Finish DTGov demos 2014-03-05 10:46:13 EST

  None (edit)
Description Stefan Bunciak 2013-10-10 09:41:14 EDT
Description of problem:

* DTGov is missing task-form when it uses dtgov-workflows installed in local maven repository.

Version-Release number of selected component (if applicable):
* 6.0.0.ER4

How reproducible:
* 100%

Steps to Reproduce:
1. Install FSW 6.0.0.ER4(-2)
2. From data run run mvn clean install
3. Create new deployment in DTGov

Actual results:

UI:
java.lang.Exception: No task form found with name: overlord.demo.CheckDeployment-taskform.xml

Server log:
http://pastebin.test.redhat.com/169432


Expected results:


Additional info:

I used dtgov-demos-switchyard (with fixed pom.xml since it contains a bug atm)
Comment 1 Kurt T Stam 2013-10-10 09:51:27 EDT
The workflows need to be deployed to S-RAMP - if it is the task forms should be extracted and the task forms will be obtained from S-RAMP. Can you check this artifact is in your repo?
Comment 2 Stefan Bunciak 2013-10-10 10:01:11 EDT
(In reply to Kurt T Stam from comment #1)
> The workflows need to be deployed to S-RAMP - if it is the task forms should
> be extracted and the task forms will be obtained from S-RAMP. Can you check
> this artifact is in your repo?

No, the dtgov-workflows were not deployed to S-RAMP at that time. That's the point - current 'state of art' requires the workflows to be present in *maven* repo, not in sramp repo, see: https://bugzilla.redhat.com/show_bug.cgi?id=1016474#c13. Correct me if I'm wrong.
After deploying the workflows to sramp repo everything works as expected.
Comment 3 Kurt T Stam 2013-10-10 10:25:48 EDT
The Project demo is work in progress and should be completed soon.
Comment 4 JBoss JIRA Server 2013-11-07 09:39:29 EST
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-88 to Resolved
Comment 5 JBoss JIRA Server 2013-11-07 12:07:58 EST
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-88 to Closed
Comment 6 Stefan Bunciak 2014-01-17 04:44:03 EST
Verified in FSW 6.0.0.CR1
Comment 7 JBoss JIRA Server 2014-03-05 10:40:51 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-88 to Reopened
Comment 8 JBoss JIRA Server 2014-03-05 10:46:14 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-88 to Closed

Note You need to log in before you can comment on or make changes to this bug.