Bug 1017839 - Backing up /etc/openshift/ should be mentioned in Procedure 3.6. Recovering a Failed Node Host
Backing up /etc/openshift/ should be mentioned in Procedure 3.6. Recovering a...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Julie
Alison Young
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 11:23 EDT by Brenton Leanhardt
Modified: 2015-07-19 20:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-07 18:59:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-10-10 11:23:42 EDT
Description of problem:

There is no mention of backing up /etc/openshift.  There are important configs under that directory, some of which are specific to a particular node.  eg, /etc/openshift/port-proxy.cfg
Comment 6 Luke Meyer 2013-10-18 09:13:12 EDT
I hesitate to add anything about backing up /etc/openshift as it's not strictly required - that's all standard config that can be easily reproduced and if they have an automated method for creating nodes, it would be generated as part of that. The only thing unique to a node in there is the public hostname and IP which they'd have from other records.

AFAICS /etc/openshift/port-proxy.cfg and /etc/openshift/node.conf are otherwise generic.

"Just keep /var/lib/openshift on an external volume" is such simple advice that I'd hate to complicate it.
Comment 7 Luke Meyer 2013-10-18 09:32:25 EDT
(In reply to Luke Meyer from comment #6)
> The only thing unique to a node in there is the
> public hostname and IP which they'd have from other records.

Turns out /etc/openshift/port-proxy.cfg DOES have node-specific stuff in it. It probably shouldn't be there, but it is for now, so ignore c6 and continue on.

Note You need to log in before you can comment on or make changes to this bug.