Bug 1017880 - OpenEXR_Viewers FTBFS: ImplicitDSO Linking issues
OpenEXR_Viewers FTBFS: ImplicitDSO Linking issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: OpenEXR_Viewers (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 12:43 EDT by Rex Dieter
Modified: 2013-10-11 15:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 15:35:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2013-10-10 12:43:29 EDT
Looks like some implicitDSO linking badness going on:

/bin/sh ../libtool --tag=CXX   --mode=link g++ -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m64 -mtune=generic -L/usr/lib64  -Wl,-z,relro  -o exrdisplay main.o ImageView.o loadImage.o scaleImage.o applyCtl.o GlWindow3d.o -lIlmImf -lImath -lHalf -lIex -lIexMath -lIlmThread -pthread -DHAVE_CTL_INTERPRETER=0  -DHAVE_CTL_INTERPRETER=0 -lIlmImf -lImath -lHalf -lIex -lIexMath -lIlmThread -pthread -Wl,-z,relro -lfltk_gl -lfltk 
libtool: link: g++ -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -Wl,-z -Wl,relro -o exrdisplay main.o ImageView.o loadImage.o scaleImage.o applyCtl.o GlWindow3d.o -pthread -DHAVE_CTL_INTERPRETER=0 -DHAVE_CTL_INTERPRETER=0 -pthread -Wl,-z -Wl,relro  -L/usr/lib64 -lIlmImf -lImath -lHalf -lIex -lIexMath -lIlmThread -lfltk_gl -lfltk -pthread
/usr/bin/ld: ImageView.o: undefined reference to symbol 'glOrtho'
/lib64/libGL.so.1: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status


See:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6047568
Comment 1 Rex Dieter 2013-10-11 15:35:32 EDT
%changelog
* Fri Oct 11 2013 Rex Dieter <rdieter@fedoraproject.org> 2.0.1-3
- OpenEXR_Viewers FTBFS: ImplicitDSO Linking issues (#1017880)

Note You need to log in before you can comment on or make changes to this bug.