Bug 1017895 - In Windows 8 client, remote-viewer.exe "--full-screen=auto-conf" does not bring the displays to full-screen
In Windows 8 client, remote-viewer.exe "--full-screen=auto-conf" does not bri...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.4.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 13:42 EDT by Bill Sanford
Modified: 2014-01-10 08:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-10 08:49:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-10-10 13:42:32 EDT
Description of problem:
Installed mingw-virt-viewer on the Windows client, and edited the remote-viewer properties to have the Target executable "remote-viewer" --full-screen=auto-conf and then launch that and input the URI:port of the VM I want to connect to. 

Both displays came up in windowed mode.

Version-Release number of selected component (if applicable):
 Windows 8.1x64 - client 
 mingw-virt-viewer-0.5.6-6.el6_4
 Windows 7x64 - guest
 rhev-guest-tools-iso-3.3-6.noarch.rpm
 RHEL6.5-20130925.2


How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Marc-Andre Lureau 2013-10-10 14:11:44 EDT
Works for me on win7,  mingw-virt-viewer-0.5.6-6.el6_4:

remote-viewer --full-screen=auto-conf spice://uri

"edited the remote-viewer properties to have the Target executable", what is that? Are you sure the arguments are passed to the client?

Can you get the virt-viewer log?
Comment 2 David Blechter 2013-11-08 15:03:46 EST
windows 8 client is low priority, was not reported on other platforms. Works fine on win7 per comment 1.
not for 3.3
Comment 3 Marc-Andre Lureau 2013-11-19 11:03:16 EST
(In reply to Marc-Andre Lureau from comment #1)
> Works for me on win7,  mingw-virt-viewer-0.5.6-6.el6_4:
> 
> remote-viewer --full-screen=auto-conf spice://uri
> 
> "edited the remote-viewer properties to have the Target executable", what is
> that? Are you sure the arguments are passed to the client?
> 
> Can you get the virt-viewer log?
Comment 6 Bill Sanford 2014-01-10 08:49:09 EST
I have retested with mingw-virt-viewer-0.5.6-18.el6_5 and this works.

Note You need to log in before you can comment on or make changes to this bug.