Bug 10179 - bad prefix (/var/tmp/...) when compiling gdb/gcc/binutils inside prc-tools
bad prefix (/var/tmp/...) when compiling gdb/gcc/binutils inside prc-tools
Status: CLOSED DEFERRED
Product: Red Hat Powertools
Classification: Retired
Component: prc-tools (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
: 10891 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-15 04:35 EST by fabrice.bellet
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 04:18:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fabrice.bellet 2000-03-15 04:35:21 EST
--- prc-tools.specs.orig	Thu Feb 24 00:23:57 2000
+++ prc-tools.spec	Sun Mar 12 11:41:23 2000
@@ -26,10 +26,10 @@
 %patch1 -p1

 %build
-make gnuuntar patch gnutools all SRCDIR="$RPM_SOURCE_DIR"
RPM_OPT_FLAGS="$RPM_OPT_FLAGS" ROOT="$RPM_BUILD_ROOT"
+make gnuuntar patch gnutools all SRCDIR="$RPM_SOURCE_DIR"
RPM_OPT_FLAGS="$RPM_OPT_FLAGS"

 %install
-mkdir -p $RPM_BUILD_ROOT/usr/man/man1
$RPM_BUILD_ROOT/usr/m68k-palmos-coff/lib
$RPM_BUILD_ROOT/usr/m68k-palmos-coff/include
$RPM_BUILD_ROOT/usr/m68k-palmos-coff/bin
+mkdir -p $RPM_BUILD_ROOT/usr/bin $RPM_BUILD_ROOT/usr/man/man1
$RPM_BUILD_ROOT/usr/m68k-palmos-coff/lib
$RPM_BUILD_ROOT/usr/m68k-palmos-coff/include
$RPM_BUILD_ROOT/usr/m68k-palmos-coff/bin
 make install RPM_OPT_FLAGS="$RPM_OPT_FLAGS" ROOT="$RPM_BUILD_ROOT"

 ( cd $RPM_BUILD_ROOT
@@ -81,6 +81,12 @@
 %defattr(-,root,root,0755)

 %changelog
+* Sun Mar 11 2000 Fabrice Bellet <Fabrice.Bellet@creatis.insa-lyon.fr>
+- build with ROOT=/ instead of $RPM_BUILD_ROOT. Only install in
+	$RPM_BUILD_ROOT. This way, binutils, gcc and gdb are
+	configured with --prefix=/usr instead of ${RPM_BUILD_ROOT}/usr.
+	So they can find their misc conf files in the directory where
+	files will finally be installed.
 * Wed Feb 23 2000 Tim Powers <timp@redhat.com>
 - don't include cccp.1 in the file list, conflicts with the cpp package
 - don't create links in /usr/bin for pilrc, it conflicts with the pilrc
Comment 1 Bernhard Rosenkraenzer 2000-08-09 04:18:17 EDT
*** Bug 10891 has been marked as a duplicate of this bug. ***
Comment 2 Bernhard Rosenkraenzer 2000-08-09 04:54:05 EDT
This will be fixed in 7.1 - we temporarily aren't shipping prc-tools in 7.0
because there's not way to get it to compile with gcc 2.96 with a reasonable
amount of work.

Note You need to log in before you can comment on or make changes to this bug.