Bug 1017909 - Without the "--full-screen=auto-conf" switch, when you "Exit Fullscreen," that closes all full-screens
Without the "--full-screen=auto-conf" switch, when you "Exit Fullscreen," tha...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 14:06 EDT by Bill Sanford
Modified: 2014-01-21 09:47 EST (History)
7 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-15.el6_5
Doc Type: Bug Fix
Doc Text:
On a guest with multiple monitors, changing one display from fullscreen mode to windowed mode also affected all other displays. Now, full screen mode is left on the current display only, allowing greater flexibility in display placement.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:47:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-10-10 14:06:01 EDT
Description of problem:
Installed mingw-virt-viewer on the Windows 8 client, and edited the remote-viewer properties to have the Target executable just "remote-viewer" without having the "--full-screen=auto-conf" part of the command-line. Then launch the remote viewer icon from the Windows 8 desktop and input the URI:port of the VM I want to connect to.

When I get both displays in windowed mode, I then put them both in full-screen. Then I would go to one of the tabs that each full-screen has to exit full-screen and left-click it to exit that display to a windowed mode. Since the "--full-screen=auto-conf" is not used, this should exit the singular display to windowed mode leaving the other display still in full-screen. However, clicking the one "Exit Fullscreen" tab, brings the other full-screen display to a windowed screen.

Version-Release number of selected component (if applicable):
 Windows 8.1x64 - client 
 mingw-virt-viewer-0.5.6-6.el6_4
 Windows 7x64 - guest
 rhev-guest-tools-iso-3.3-6.noarch.rpm
 RHEL6.5-20130925.2

How reproducible:
100% 

Steps to Reproduce:
1. See Above
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Marc-Andre Lureau 2013-11-06 05:40:32 EST
Fixed by upstream

commit a8c71751cd4ae81bc12e3a81bfe1e7eb08ac41c9
    window: leave fullscreen on current window

    Since fdaa9b0ca, virt-viewer allows to fullscreen a single window. It
    feels more symetric to leave a single window from fullscreen as well,
    unless the application was started in fullscreen.
Comment 4 Charlie 2013-11-27 20:27:30 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 09:47:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.