Bug 1017919 - anaconda: "add a keyboard layout" dialogue doesn't support searching by first letter of the language
anaconda: "add a keyboard layout" dialogue doesn't support searching by first...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 14:40 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2013-10-21 03:14 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 08:15:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-10-10 14:40:02 EDT
Description of problem:
The list is long, and I wanted to select a layout starting with "P". I'd expect "P" to jump to layouts starting with "P".

Version-Release number of selected component (if applicable):
anaconda installer from http://download.fedoraproject.org/pbu/fedora/linux/development/20/x86_64/os/ (sorry I don't see a version number anywhere, anaconda --version or anaconda --help starts the installation.)
Comment 1 Vratislav Podzimek 2013-10-17 08:15:51 EDT
It filters the list down to layouts containing the entered string. This way it is easier to e.g. find all US layouts. I cannot fix this, trying to match the entered string with the start of layout description would complicate other use cases. So the way it works now is intentional and thus not a bug.
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-10-18 13:08:23 EDT
OK, I retested this now, and indeed it works like you say. I guess I was confused by the fact that the string needs to be entered in the box below, and it is not enough to click on the list and start typing... But that's a minor issue.

Let me just say that the current Anaconda interface is *very* pleasant to use.
Comment 3 Vratislav Podzimek 2013-10-21 03:14:52 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #2)
> OK, I retested this now, and indeed it works like you say. I guess I was
> confused by the fact that the string needs to be entered in the box below,
> and it is not enough to click on the list and start typing... But that's a
> minor issue.
> 
> Let me just say that the current Anaconda interface is *very* pleasant to
> use.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.