Bug 1017963 - 'Metadata inconsistency' messages when creating thin vols w/ lvmetad running
'Metadata inconsistency' messages when creating thin vols w/ lvmetad running
Status: CLOSED DUPLICATE of bug 1003441
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.5
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 16:52 EDT by Corey Marthaler
Modified: 2013-10-11 06:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 06:35:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2013-10-10 16:52:13 EDT
Description of problem:
[root@virt-040 ~]# lvs -a -o +devices
 LV              VG            Attr       LSize   Data% Devices
 POOL            snapper_thinp twi-a-tz--   1.00g  0.00 POOL_tdata(0)
 [POOL_tdata]    snapper_thinp Twi-ao----   1.00g       /dev/sdd1(1)
 [POOL_tmeta]    snapper_thinp ewi-ao----   4.00m       /dev/sdb1(0)
 [lvol0_pmspare] snapper_thinp ewi-------   4.00m       /dev/sdd1(0)

[root@virt-040 ~]# lvcreate --virtualsize 1G -T snapper_thinp/POOL -n origin
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.
 Metadata inconsistency: Not all flags successfully exported.

Version-Release number of selected component (if applicable):
2.6.32-421.el6.x86_64

lvm2-2.02.100-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
lvm2-libs-2.02.100-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
lvm2-cluster-2.02.100-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
udev-147-2.48.el6    BUILT: Fri Aug  9 13:09:50 CEST 2013
device-mapper-1.02.79-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
device-mapper-libs-1.02.79-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
device-mapper-event-1.02.79-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
device-mapper-event-libs-1.02.79-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
cmirror-2.02.100-5.el6    BUILT: Wed Oct  9 17:45:04 CEST 2013
Comment 2 Alasdair Kergon 2013-10-10 17:09:01 EDT
Should be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1003441#c16

Close as duplicate once it's fixed.
Comment 3 Peter Rajnoha 2013-10-11 06:35:59 EDT
(In reply to Alasdair Kergon from comment #2)
> Should be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1003441#c16

That's exactly the case...

*** This bug has been marked as a duplicate of bug 1003441 ***

Note You need to log in before you can comment on or make changes to this bug.