Bug 1017987 - tc -show not showing proper rate for htb qdisc
tc -show not showing proper rate for htb qdisc
Status: CLOSED DUPLICATE of bug 1011281
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 18:15 EDT by Jean-Luc Duprat
Modified: 2013-10-14 11:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 11:03:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Luc Duprat 2013-10-10 18:15:15 EDT
Description of problem:

The reported packet flow rates from this command are now all zero.
This used to be correctly tracked until recently.

$ tc -s -d class show dev wan

class htb 1:10 parent 1:1 leaf 10: prio 0 quantum 4687 rate 375000bit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 36Kb/1 mpu 0b overhead 0b level 0 
 Sent 560393402 bytes 8020742 pkt (dropped 0, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 7376062 borrowed: 644680 giants: 0
 tokens: 2026000 ctokens: 2044333

class htb 1:1 root rate 2250Kbit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 6Kb/1 mpu 0b overhead 0b level 7 
 Sent 2096155811 bytes 11619050 pkt (dropped 0, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 987059 borrowed: 0 giants: 0
 tokens: 334772 ctokens: 334772

class htb 1:20 parent 1:1 leaf 20: prio 1 quantum 4687 rate 375000bit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 36Kb/1 mpu 0b overhead 0b level 0 
 Sent 17924994 bytes 40601 pkt (dropped 13, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 33626 borrowed: 3615 giants: 0
 tokens: 2026000 ctokens: 2044333

class htb 1:30 parent 1:1 leaf 30: prio 2 quantum 4687 rate 375000bit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 36Kb/1 mpu 0b overhead 0b level 0 
 Sent 166232976 bytes 124687 pkt (dropped 0, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 23963 borrowed: 30030 giants: 0
 tokens: 2026000 ctokens: 2044333

class htb 1:40 parent 1:1 leaf 40: prio 3 quantum 4687 rate 375000bit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 36Kb/1 mpu 0b overhead 0b level 0 
 Sent 15507617 bytes 133991 pkt (dropped 0, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 131244 borrowed: 2747 giants: 0
 tokens: 1999638 ctokens: 2041304

class htb 1:50 parent 1:1 leaf 50: prio 4 quantum 4687 rate 375000bit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 36Kb/1 mpu 0b overhead 0b level 0 
 Sent 290397052 bytes 543488 pkt (dropped 0, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 509693 borrowed: 3070 giants: 0
 tokens: 2008666 ctokens: 2041444

class htb 1:60 parent 1:1 leaf 60: prio 5 quantum 4687 rate 375000bit ceil 2250Kbit burst 6Kb/1 mpu 0b overhead 0b cburst 36Kb/1 mpu 0b overhead 0b level 0 
 Sent 1045699770 bytes 2755541 pkt (dropped 1341, overlimits 0 requeues 0) 
 rate 0bit 0pps backlog 0b 0p requeues 0 
 lended: 2171862 borrowed: 302917 giants: 0
 tokens: 2002000 ctokens: 2040333

Version-Release number of selected component (if applicable):

kernel: Linux 3.11.3-201.fc19.i686.PAE #1 SMP Thu Oct 3 01:11:40 UTC 2013 i686 i686 i386 GNU/Linux
iproute-3.9.0-2.fc19.i686

How reproducible:

$ tc -s -d class show dev wan | grep -i "^ rate [0-9]*bit" | cut -d' ' -f -4

Actual results:

 rate 0bit 0pps
 rate 0bit 0pps
 rate 0bit 0pps
 rate 0bit 0pps
 rate 0bit 0pps
 rate 0bit 0pps
 rate 0bit 0pps

Expected results:

These rates used to accurately reflect packet flow rates.

Additional info:
Comment 1 Petr Šabata 2013-10-11 04:08:03 EDT
(In reply to Jean-Luc Duprat from comment #0)
> Description of problem:
> 
> The reported packet flow rates from this command are now all zero.
> This used to be correctly tracked until recently.

Being a little more specific here would be helpful.
Do you remember what you've updated? (distro, iproute, kernel)
Comment 2 Jean-Luc Duprat 2013-10-11 14:53:02 EDT
Not specifically as this is not something I check particularly regularly.  
This is on an up-to-date F19.  It used to work a few weeks ago on F19.

First question that comes to mind is whether the kernel is reporting the right data.  Is there a way to examine the source for this data via /proc or in /sys?
Comment 3 Petr Šabata 2013-10-14 01:41:15 EDT
(In reply to Jean-Luc Duprat from comment #2)
> Not specifically as this is not something I check particularly regularly.  
> This is on an up-to-date F19.  It used to work a few weeks ago on F19.

Thanks.

> First question that comes to mind is whether the kernel is reporting the
> right data.  Is there a way to examine the source for this data via /proc or
> in /sys?

I'm not aware of that.  tc gets this data from netlink and there haven't been any changes in the userspace code in a while.

Switching to kernel.
Comment 4 Jean-Luc Duprat 2013-10-14 10:47:24 EDT
Updated kernel to 3.11.4-201.fc19.i686.PAE but same behavior.
Comment 5 Josh Boyer 2013-10-14 11:03:13 EDT
I believe this is a duplicate of 1011281

*** This bug has been marked as a duplicate of bug 1011281 ***

Note You need to log in before you can comment on or make changes to this bug.