Bug 1017996 - Scaling not choosing random hosts
Scaling not choosing random hosts
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jordan Liggitt
Wei Sun
Depends On:
  Show dependency treegraph
Reported: 2013-10-10 19:45 EDT by Diego Castro
Modified: 2017-05-31 14:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Diego Castro 2013-10-10 19:45:07 EDT
Description of problem:
After change scaling limits the broker create all gears on the same node on a district with 3 nodes

Version-Release number of selected component (if applicable):

How reproducible:

Create a district with 3 nodes
Create a scaled app
Change scaling limits to --min 3 --max 6

Actual results:

Almost all gears are running on unique node

Expected results:

The gears should be distributed and the node with less gears running should be used

Additional info:
Comment 1 Abhishek Gupta 2014-02-25 17:06:08 EST
I tried this on a 2-node setup and it worked. The new gears were shared between the nodes. Selecting a node to host a gear also depends on the active capacity of the node, among other factors. 

If this still does not work for your specific use case, you now have the ability to provide your own implementation. We recently introduced the feature to allow admins to provide their own node selection algorithm by implementing the plugin. Refer origin-server/controller/lib/openshift/application_container_proxy.rb for more details. Also take a look at the test case --> origin-server/broker/test/functional/node_selection_plugin_test.rb
Comment 2 Diego Castro 2014-02-26 11:31:18 EST
Thank you for your comments, this is a very old bug and was filled on Origin Release 2.
Comment 3 weiwei jiang 2016-02-04 00:03:16 EST
Checked with devenv_5760, and can not reproduce this issue.
Comment 5 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.