Bug 1018012 - ERROR with transaction check vs depsolve
ERROR with transaction check vs depsolve
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 21:08 EDT by bpk678
Modified: 2013-10-11 18:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 18:00:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bpk678 2013-10-10 21:08:51 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: only tried one


Steps to Reproduce:
1. yum check-update
2. yum upgrade -y
3. find error reported to std out

Actual results:
Running Transaction Check
ERROR with transaction check vs depsolve:
rubygem-locale = 2.0.5-2.fc15.1 is needed by (installed) ruby-locale-2.0.5-2.fc15.1.noarch
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum

Expected results:
rubygem-locale should be upgraded

Additional info:
not sure what the issue is, but why is fc15 being cited in the version strings when the OS is 18 and the existing installed package is rubygem-locale-2.0.8-1.fc18.noarch
Comment 1 Jan Zeleny 2013-10-11 02:30:12 EDT
This is not a bug in yum. The fc15 referenced in your packages means you have not updated those packages since F15. But the root cause is that the package ruby-locale blocks your update, yum just reports the update is being blocked. Uninstall the ruby-locale and everything will work.
Comment 2 bpk678 2013-10-11 17:49:42 EDT
this cannot be an issue with fedora 15 remnants or lack of updates since then.  this box was build from scratch with Fedora 17 and fedup'd to 18.  there has never been a Fedora 15 instance on this device.
Comment 3 bpk678 2013-10-11 18:00:57 EDT
i'll shut my mouth... i was checking on the wrong device.  F15 was installed on the device with this issue.

Note You need to log in before you can comment on or make changes to this bug.