Bug 1018049 - csh login/non-login history configuration is incorrect
csh login/non-login history configuration is incorrect
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tcsh (Show other bugs)
6.6
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jaromír Končický
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 01:20 EDT by Pavel Raiskup
Modified: 2014-07-01 18:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 01:52:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2013-10-11 01:20:37 EDT
a) If 'tcsh' is run as non-login shell, the '$history' value has greater value
   than the value in '$savehist', which is bad according to tcsh documentation.

b) If 'tcsh' is run as login shell, the '$savehist' does not have the keyword
   'merge' inside.  This may (quite unlikely, though) trim the ~/.history file.
Comment 1 Pavel Raiskup 2013-10-11 01:32:05 EDT
I problem b) should be treat as high severity.  If user has set the default
shell to 'tcsh', the first starting and last shutdown tcsh instance is run as
login shell - thus, most likely, the history file is going to be truncated.
Comment 2 Pavel Raiskup 2013-10-11 01:42:25 EDT
Ok, scratch the comment #1, that is not truth.  I had misconfigured local
settings.  But the a) case seems to be still issue, though with much lower
severity.
Comment 3 Pavel Raiskup 2013-10-11 01:52:49 EDT
Looking it once again and even the a) case seems to be innocent to me (the
only thing what happens is that max(savehist, history) number of history
entries will be saved at shutdown).  Thus closing, sorry for noise.

Note You need to log in before you can comment on or make changes to this bug.