This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1018063 - Upgrade set wrong ownership of user home dir
Upgrade set wrong ownership of user home dir
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Ryan Barry
Virtualization Bugs
node
:
: 1094872 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 02:37 EDT by Guohua Ouyang
Modified: 2016-02-10 15:11 EST (History)
21 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, a new CIM group added in the %post script created ownership problems of plugins when upgrading from a pre-plugin version of Red Hat Enterprise Virtualization. Now, the %post script logic has been improved to avoid this problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-11 15:46:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 880213 None None None Never
oVirt gerrit 20302 None None None Never

  None (edit)
Description Guohua Ouyang 2013-10-11 02:37:52 EDT
Description of problem:
After upgrade from 6.4 to 6.5 or downgrade 6.5 to 6.4, the user home dir ownership is wrong.

#ll /home/
total 16
drwx------. 2 cim   admin 4096 Oct  7 05:07 admin
drwx------. 2 admin cim   4096 Oct  7 05:04 cim

Version-Release number of selected component (if applicable):
Rhev-hypervisor6-6.5-20130930.0.auto665

How reproducible:
100%

Steps to Reproduce:
1.

Actual results:

Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2013-10-14 21:34:52 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 Cheryn Tan 2013-11-07 19:36:37 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 13 Ryan Barry 2014-05-06 15:20:19 EDT
*** Bug 1094872 has been marked as a duplicate of this bug. ***
Comment 16 Fabian Deutsch 2014-07-24 12:02:44 EDT
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.
Comment 17 Guohua Ouyang 2014-12-12 03:01:39 EST
verified on 6.6-20141119.0 build, upgrade from a 6.5 build to this build, the ownership of /home is correct.
Comment 19 errata-xmlrpc 2015-02-11 15:46:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html

Note You need to log in before you can comment on or make changes to this bug.