Bug 1018126 - Font *helvetica* not seen by fc-list or in system-preferences-appearance.
Font *helvetica* not seen by fc-list or in system-preferences-appearance.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-fonts (Show other bugs)
6.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On:
Blocks: 1075802
  Show dependency treegraph
 
Reported: 2013-10-11 05:49 EDT by amit yadav
Modified: 2014-12-08 04:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 04:35:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 510333 None None None Never

  None (edit)
Description amit yadav 2013-10-11 05:49:16 EDT
Description of problem:

All required "xorg-x11-fonts" font packages are installed on the system but helvetica fonts can't be used in following commands/applications:

# fc-list

or by

# system-preferences-appearance

or by

# gnome-terminal     (In profile font settings)

Above applications are not displaying this font in settings, so unable to select them.


Version-Release number of selected component (if applicable):
xorg-x11-fonts*

How reproducible:
Always

Steps to Reproduce:
1. Make sure following packages are installed on the system

xorg-x11-fonts-100dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-75dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-9-100dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-2-75dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-15-75dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-15-100dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-2-100dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-9-75dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-14-100dpi-7.2-9.1.el6.noarch
xorg-x11-fonts-ISO8859-14-75dpi-7.2-9.1.el6.noarch

2. Run  below command:

   # fc-list| grep -i hel


Actual results:

It will not display helvetica fonts

Expected results:

It should display helvetica fonts

Additional info:

[Workaround]

By manually defining fonts in /etc/fonts/fonts.conf file with these lines:

<snip>

<dir>/usr/share/X11/fonts/75dpi</dir>
    <dir>/usr/share/X11/fonts/100dpi</dir>

</snip>

and excuting below commands it can be listed in those applications:

 # fc-cache -f -v
Comment 1 RHEL Product and Program Management 2013-10-13 19:00:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Peter Hutterer 2014-12-02 19:19:57 EST
local workaround: 
Save the following snippet as /etc/fonts/conf.d/01-xorg-x11-fonts.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<dir>/usr/share/X11/fonts/75dpi</dir>
	<dir>/usr/share/X11/fonts/100dpi</dir>
</fontconfig>

Then run fc-cache -fv, verify the font is listed with fc-list | grep Helvetica

Dropping this file into the directory is simpler than editing the fonts.conf file and scriptable for multiple deployments.

Note that enabling fontconfig to find these files has undesirable impact on other applications. For example, if Helvetica is listed Firefox prefers that font over the nicer-looking aliased ones. This gives a number of websites a distinctively 80s look. Reproducible by running the above commands, then opening a html file containing:

<html>
    <body>
        <p style="font-family:helvetica">How does this text look?</p>
    </body>
</html>
Comment 8 RHEL Product and Program Management 2014-12-08 04:35:50 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.