This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1018134 - Can not restart after force-stop the app for nodejs-0.6 and nodejs-0.10 after migration in STG
Can not restart after force-stop the app for nodejs-0.6 and nodejs-0.10 after...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 06:14 EDT by Yan Du
Modified: 2015-05-14 19:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-10-11 06:14:32 EDT
Description of problem:
Can not restart after force-stop the app for nodejs-0.6 and nodejs-0.10 after migration


Version-Release number of selected component (if applicable):
STG(devenv-stage_493)


How reproducible:
Always


Steps to Reproduce:

1. Create a nodejs app (nodejs-0.6 or nodje-0.10)
#rhc app create n6 nodejs-0.6
2. do migration
3. rhc app-force-stop n6
4. rhc app restart n6


Actual results:

[root@Daphne test]# arestart n6 -d
Unable to complete the requested operation due to: Failed to correctly execute all parallel
operations.


Expected results:
should restart app normally after force-stop


Additional info:

rhc ssh the app to check the control script, found the code in https://github.com/openshift/origin-server/commit/fe4b4d708bf48abc6d2961502fee16da5a66d779  didn't update to old nodejs app.
Comment 1 Xiaoli Tian 2013-10-11 06:34:53 EDT
I guess we have not bumped up cartridge versions for all  cartridges having changes for sprint 34 yet, that will cause most changes for cartridges can not be upgraded successfully in STG since STG is running oo-admin-upgrade without --ignore-cartridge-version option
Comment 2 Yan Du 2013-10-11 22:58:46 EDT
Test on STG(devenv-stage_496), the issue can't be reproduced. nodejs app can be controlled normally.
Comment 3 Yan Du 2013-10-16 04:14:37 EDT
Move bug to verified according to #Comment 2

Note You need to log in before you can comment on or make changes to this bug.