Bug 1018186 - Redhat is missing libnetfilter queue related packages
Redhat is missing libnetfilter queue related packages
Status: CLOSED DUPLICATE of bug 738244
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.6
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: RHEL Product and Program Management
nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 07:57 EDT by Miika Komu
Modified: 2014-07-23 10:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-23 10:42:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miika Komu 2013-10-11 07:57:00 EDT
Description of problem:

libipq library is deprecated and the associated kernel modules are absent from the latest kernel versions. The replacement for libipq is libnetfilter. However, in order to use libnetfilter you need (i) libnetfilter-queue and (ii) the associated development package (with headers etc). These two packages are missing from Redhat, which renders the software depending on libnetfilter broken on Redhat. The two libraries are included in Debian, Ubuntu and Fedora.

Version-Release number of selected component (if applicable):

All releases, including the latest 6.4

How reproducible:

Try to install libnetfilter queue and the development package in Redhat. N/A.

Additional info:

The package seems to be installable from here, but I don't think it's available in the official Redhat:

ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/security%3A/netfilter/RHEL_6/i686/libnetfilter_queue1-1.0.2-34.1.i686.rpm
ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/security%3A/netfilter/RHEL_6/x86_64/libnetfilter_queue-devel-1.0.2-34.1.x86_64.rpm

Kernel news:

http://lxr.linux.no/linux+v3.9/Documentation/ABI/removed/ip_queue
Comment 2 RHEL Product and Program Management 2013-10-13 19:00:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Miika Komu 2013-10-14 03:28:24 EDT
(In reply to RHEL Product and Program Management from comment #2)
> This request was evaluated by Red Hat Product Management for
> inclusion in the current release of Red Hat Enterprise Linux.
> Because the affected component is not scheduled to be updated
> in the current release, Red Hat is unable to address this
> request at this time.
> 
> Red Hat invites you to ask your support representative to
> propose this request, if appropriate, in the next release of
> Red Hat Enterprise Linux.

Can I change this bug request to target the next release or how should proceed with this?
Comment 5 Eric Dubé 2014-07-23 10:42:00 EDT

*** This bug has been marked as a duplicate of bug 738244 ***

Note You need to log in before you can comment on or make changes to this bug.