Bug 1018244 - Calendar view sometimes does not showing
Calendar view sometimes does not showing
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mauricio Salatino
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 10:24 EDT by Pedro Zapata
Modified: 2014-08-06 16:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Calendar view not showing (142.53 KB, image/png)
2013-10-11 10:24 EDT, Pedro Zapata
no flags Details

  None (edit)
Description Pedro Zapata 2013-10-11 10:24:51 EDT
Created attachment 811153 [details]
Calendar view not showing

In some scenarios, probably related to the amount of tasks, the calendar view of the task list does not show up. When you click the 'Calendar' view nothing happens (see attached screenshot).

--------------------
Caused by: java.lang.IndexOutOfBoundsException: Row index: 10, Row size: 30  at com.google.gwt.user.cellview.client.AbstractHasData.checkRowBounds(AbstractHasData.java:988)  at com.google.gwt.user.cellview.client.AbstractCellTable.getSubRowElement(AbstractCellTable.java:2276)  at com.google.gwt.user.cellview.client.AbstractCellTable.getChildElement(AbstractCellTable.java:1726)  at 
Caused by: java.lang.IndexOutOfBoundsException: Row index: 10, Row size: 30  at com.google.gwt.user.cellview.client.AbstractHasData.checkRowBounds(AbstractHasData.java:988)  at com.google.gwt.user.cellview.client.AbstractCellTable.getSubRowElement(AbstractCellTable.java:2276)  at com.google.gwt.user.cellview.client.AbstractCellTable.getChildElement(AbstractCellTable.java:1726)  at 
Caused by: java.lang.IndexOutOfBoundsException: Row index: 10, Row size: 30  at com.google.gwt.user.cellview.client.AbstractHasData.checkRowBounds(AbstractHasData.java:988)  at com.google.gwt.user.cellview.client.AbstractCellTable.getSubRowElement(AbstractCellTable.java:2276)  at com.google.gwt.user.cellview.client.AbstractCellTable.getChildElement(AbstractCellTable.java:1726)  at 
Caused by: java.lang.IndexOutOfBoundsException: Row index: 10, Row size: 30  at com.google.gwt.user.cellview.client.AbstractHasData.checkRowBounds(AbstractHasData.java:988)  at com.google.gwt.user.cellview.client.AbstractCellTable.getSubRowElement(AbstractCellTable.java:2276)  at com.google.gwt.user.cellview.client.AbstractCellTable.getChildElement(AbstractCellTable.java:1726)  at 
Caused by: java.lang.IndexOutOfBoundsException: Row index: 10, Row size: 30  at com.google.gwt.user.cellview.client.AbstractHasData.checkRowBounds(AbstractHasData.java:988) 
 at com.google.gwt.user.cellview.client.AbstractCellTable.getSubRowElement(AbstractCellTable.java:2276)  at com.google.gwt.user.cellview.client.AbstractCellTable.getChildElement(AbstractCellTable.java:1726)  at com.google.gwt.user.cellview.client.AbstractCellTable.getRowElement(AbstractCellTable.java:1196)  at org.jbpm.console.ng.ht.client.util.DataGridUtils.getIdRowSelected(DataGridUtils.java:118)  at 
<salaboy> org.jbpm.console.ng.ht.client.util.DataGridUtils.paintCalendarFromGrid(DataGridUtils.java:140)  at org.jbpm.console.ng.ht.client.editors.taskslist.TasksListViewImpl.refreshCalendarView(TasksListViewImpl.java:322)
Comment 2 Mauricio Salatino 2013-10-15 09:18:07 EDT
Fixed in 6.0.x and master: http://github.com/droolsjbpm/jbpm-console-ng/compare/1f6d25f...7384eaa
Comment 3 Tomas Livora 2013-12-04 05:48:05 EST
Verified on BPMS 6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.