Bug 1018268 - Non-fatal warnings generated by ER4.respin3 installer on RHEL6 and Windows7
Non-fatal warnings generated by ER4.respin3 installer on RHEL6 and Windows7
Status: CLOSED DUPLICATE of bug 1001535
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Eric Wittmann
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 11:14 EDT by Len DiMaggio
Modified: 2015-08-02 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 09:03:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Install log (248.46 KB, text/plain)
2013-10-11 11:16 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-10-11 11:14:36 EDT
Description of problem:

These warnings are showing up near the end of the installer's run:

JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$CollectionView$CollectionViewIterator.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$KeySet.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$CollectionView.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/ArrayStack.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$EntrySet.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)
JarClassLoader: Warning: org/apache/commons/collections/FastHashMap$Values.class in lib/commons-beanutils-1.8.3-redhat-2.jar is hidden by lib/commons-collections-3.2.1-redhat-2.jar (with different bytecode)

There doesn't seem to be a functional impact.

Version-Release number of selected component (if applicable):

FSW6.ER4.respin3
Oracle Java 1.7 on Windows7
OpenJDK 1.7 on RHEL6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Thomas Hauser 2013-10-11 11:16:01 EDT
These warnings are output by the s-ramp jar execution itself. You can reproduce this by running the s-ramp CLI outside of the installer as well.
Comment 2 Len DiMaggio 2013-10-11 11:16:17 EDT
Created attachment 811215 [details]
Install log
Comment 4 Eric Wittmann 2013-10-24 09:03:31 EDT

*** This bug has been marked as a duplicate of bug 1001535 ***

Note You need to log in before you can comment on or make changes to this bug.