Bug 1018278 - Packaging errors in HA Agent
Packaging errors in HA Agent
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Greg Padgett
Artyom
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 11:28 EDT by Greg Padgett
Modified: 2016-06-12 19:16 EDT (History)
9 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-ha-0.1.0-0.3.1.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:50:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20120 None None None Never

  None (edit)
Description Greg Padgett 2013-10-11 11:28:35 EDT
There are some latent packaging issues in the HA agent that need to be addressed.  This bug is for allowing those found issues to be submitted/merged to get the packaging in shape.

The first issue, which prompted this, is that the .spec.in file needs to be distributed in the tarball.
Comment 1 Greg Padgett 2013-10-11 11:32:41 EDT
http://gerrit.ovirt.org/20120 - distribute .spec.in in tarball
Comment 2 Greg Padgett 2013-10-15 08:56:17 EDT
Merged Change-Id: I86c804f39a23b4cc905d52f74fb7621bf9e80bc4
Comment 4 Ilanit Stein 2013-10-27 10:45:37 EDT
Can you please explain how this bug can be verified?
thanks.
Comment 5 Greg Padgett 2013-10-28 07:35:43 EDT
I checked with Sandro on this one, you should be able to:
"download the .src.rpm from the yum repository / brew and check if the included tarball contains the .spec.in

rpm -i ...src.rpm
cd ~/rpmbuild/SOURCES
tar tvf .....tar.gz|grep spec.in
"
Comment 6 Artyom 2013-10-28 09:47:06 EDT
Verified ovirt-hosted-engine-ha-0.1.0-0.3.1.beta1.el6ev
ovirt-hosted-engine-ha-0.1.0-0.3.1.beta1/ovirt-hosted-engine-ha.spec.in
Comment 7 Charlie 2013-11-27 20:42:14 EST
This bug is currently attached to errata RHEA-2013:15591. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 Greg Padgett 2013-12-06 13:00:15 EST
ovirt-hosted-engine-ha is a new package; does not need errata for bugs during its development.
Comment 9 errata-xmlrpc 2014-01-21 11:50:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0080.html

Note You need to log in before you can comment on or make changes to this bug.