Bug 1018394 - tomcat fails to start on ipv6
tomcat fails to start on ipv6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tomcat6 (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Knox
tomcat-qe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 16:55 EDT by Ade Lee
Modified: 2015-11-01 19:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-20 14:35:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Lee 2013-10-11 16:55:19 EDT
Description of problem:

On a server on which ipv6 is enabled and ipv4 is not enabled - and the ipv4 localhost is configured in /etc/hosts, tomcat fails to start because the shutdown port will attempt to bind to the ipv4 localhost.

A better approach might be to cycle through both ipv4 and ipv6 interfaces - and only fail if neither is available.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2013-10-14 21:33:43 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 David Knox 2013-11-04 14:08:29 EST
tomcat assumes localhost so perhaps a better solution is to use InetAddress.getLocalHost().getHostAddress()
Comment 5 David Knox 2014-10-20 14:21:31 EDT
unfortunately, tomcat6-6.0.24 hard codes 'localhost' in several places.

there has been success on ipv6-only systems when localhost is mapped to the ipv6 address.
Comment 6 RHEL Product and Program Management 2014-10-20 14:35:48 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.