Bug 1018547 - NFS server keeps constantly dying
NFS server keeps constantly dying
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.4.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: santosh pradhan
:
Depends On:
Blocks: 1019064
  Show dependency treegraph
 
Reported: 2013-10-13 03:13 EDT by Bjoern Teipel
Modified: 2014-09-21 18:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1019064 (view as bug list)
Environment:
Last Closed: 2014-04-17 09:14:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bjoern Teipel 2013-10-13 03:13:33 EDT
Description of problem:

pending frames:
frame : type(0) op(0)
frame : type(0) op(0)
frame : type(0) op(0)

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2013-10-11 15:50:02configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.4.1
/lib64/libc.so.6(+0x32920)[0x7fa789fb3920]
/usr/lib64/libglusterfs.so.0(uuid_unpack+0x0)[0x7fa78ad3d020]
/usr/lib64/libglusterfs.so.0(+0x46cf6)[0x7fa78ad3ccf6]
/usr/lib64/libglusterfs.so.0(uuid_utoa+0x37)[0x7fa78ad1c3a7]
/usr/lib64/glusterfs/3.4.1/xlator/nfs/server.so(__mnt3_resolve_export_subdir_comp+0x164)[0x7fa77f941bd4]
/usr/lib64/glusterfs/3.4.1/xlator/nfs/server.so(mnt3_resolve_subdir_cbk+0x14c)[0x7fa77f9429ac]
/usr/lib64/glusterfs/3.4.1/xlator/nfs/server.so(nfs_fop_lookup_cbk+0x10a)[0x7fa77f93b0ca]
/usr/lib64/glusterfs/3.4.1/xlator/debug/io-stats.so(io_stats_lookup_cbk+0x113)[0x7fa77fdf11e3]
/usr/lib64/glusterfs/3.4.1/xlator/cluster/distribute.so(dht_lookup_dir_cbk+0x27f)[0x7fa78434bfdf]
/usr/lib64/glusterfs/3.4.1/xlator/protocol/client.so(client3_3_lookup_cbk+0x655)[0x7fa78458b985]
/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa5)[0x7fa78aaee6f5]
/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0x11f)[0x7fa78aaefc6f]
/usr/lib64/libgfrpc.so.0(rpc_transport_notify+0x28)[0x7fa78aaeb4e8]
/usr/lib64/glusterfs/3.4.1/rpc-transport/socket.so(+0x91d6)[0x7fa7867c51d6]
/usr/lib64/glusterfs/3.4.1/rpc-transport/socket.so(+0xabfd)[0x7fa7867c6bfd]
/usr/lib64/libglusterfs.so.0(+0x5e207)[0x7fa78ad54207]
/usr/sbin/glusterfs(main+0x5e8)[0x406818]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7fa789f9fcdd]
/usr/sbin/glusterfs[0x404659]
---------
[2013-10-11 16:24:11.713895] I [glusterfsd.c:1910:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.4.0 (/usr/sbin/glusterfs -s localhost --volfile-id gluster/nfs -p /var/l
ib/glusterd/nfs/run/nfs.pid -l /var/log/glusterfs/nfs.log -S /var/run/d219ef31c7bee1aa1c37de64280d738f.socket)

Version-Release number of selected component (if applicable):

3.4.1

How reproducible:

N/A

Steps to Reproduce:
1.
2.
3.

Actual results:

Gluster NFS process dies and need to be manually restarted

Expected results:

No crash

Additional info:
Comment 1 Anand Avati 2013-10-13 11:23:09 EDT
REVIEW: http://review.gluster.org/6083 (nfs/mount3: fix crash in subdir resolution) posted (#1) for review on release-3.4 by Santosh Pradhan (spradhan@redhat.com)
Comment 2 Anand Avati 2013-10-14 13:20:51 EDT
COMMIT: http://review.gluster.org/6083 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 1ce54da9679c53d9e7af787a255ec0ad11aa1ac0
Author: Santosh Kumar Pradhan <spradhan@redhat.com>
Date:   Sun Oct 13 20:42:57 2013 +0530

    nfs/mount3: fix crash in subdir resolution
    
    * __mnt3_resolve_export_subdir_comp: if nfs_entry_loc_fill fails,
      mres->resolveloc does not contain valid data
    * gf_log should use 'gfid' instead of mres->resolveloc.inode->gfid
    * fixes a crash if program flow gets to this line
    
    Backport FIX link: http://review.gluster.org/4948
    
    Signed-off-by: Santosh Kumar Pradhan <spradhan@redhat.com>
    
    Change-Id: I6dea17ae3f07210430a0b71bd08be6f59f739c9a
    BUG: 1018547
    Signed-off-by: Santosh Kumar Pradhan <spradhan@redhat.com>
    Reviewed-on: http://review.gluster.org/6083
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Niels de Vos 2014-04-17 09:14:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.