Bug 1018744 - windows 2003 32-bit guest not display properly with '-vga cirrus' or '-vga stdio'
windows 2003 32-bit guest not display properly with '-vga cirrus' or '-vga st...
Status: CLOSED DUPLICATE of bug 979898
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: seabios (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 06:55 EDT by Xu Han
Modified: 2014-01-16 21:46 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 21:46:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (38.52 KB, image/png)
2013-10-14 06:59 EDT, Xu Han
no flags Details
device-driver-screenshot (21.76 KB, image/png)
2013-10-20 23:18 EDT, Xu Han
no flags Details
screen shot(seabios-1.7.2.2-8) (105.23 KB, image/png)
2014-01-16 21:45 EST, Xu Han
no flags Details

  None (edit)
Description Xu Han 2013-10-14 06:55:41 EDT
Description of problem:
windows 2003 32-bit guest not display properly with '-vga cirrus' or '-vga stdio', but with '-vga qxl' guest can display properly.

windows 2003 64-bit guest not hit this issue.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-9.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot win2003 32-bit guest with '-vga cirrus'
# /usr/libexec/qemu-kvm -net none -M pc -m 2G -cpu SandyBridge -smp 4,cores=2,threads=2,sockets=1 -monitor stdio -vnc :1 \
-drive file=/home/win2003-32.qcow2,if=none,id=guest-img \
-device ide-hd,drive=guest-img,id=os-disk \
-vga cirrus

2. use remote-viewer or vncviewer connect to guest
# remote-viewer vnc://$HOST_IP:5901

3.

Actual results:
guest not display properly.

Expected results:
guest display properly

Additional info:
not install any display driver in guest.
Comment 1 Xu Han 2013-10-14 06:59:07 EDT
Created attachment 811947 [details]
screen shot
Comment 3 Yan Vugenfirer 2013-10-17 03:48:39 EDT
What's the status with upstream?
Comment 5 Gerd Hoffmann 2013-10-17 05:03:58 EDT
What is the RHEL-6 status (i.e. is it a regression)?
Which driver is used by windows (check device manager)?  cirrus or generic?
Did you test qxl with or without guest drivers?
Comment 6 Xu Han 2013-10-20 23:18:57 EDT
Created attachment 814388 [details]
device-driver-screenshot

1. RHEL6 has no such issue. (test on RHEL7 with qemu-kvm-1.4.0-3.el7.x86_64 hit this issue as well, so it is not a regression.)
2. Guest use cirrus driver. (has a screenshot in attachment)
3. Guest GUI work properly both with and without qxl driver.
Comment 7 Gerd Hoffmann 2014-01-15 09:28:59 EST
Turned out to be a vgabios issue.  With latest seavgabios everything works fine.
So we have to backport some cirrus fixes to seabios ...
Comment 8 Gerd Hoffmann 2014-01-16 10:27:05 EST
please retest with seabios-1.7.2.2-8.el7
[ likely a dup of bug 979898 ]
Comment 9 Xu Han 2014-01-16 21:45:42 EST
Created attachment 851379 [details]
screen shot(seabios-1.7.2.2-8)

Tested this issue with seabios-1.7.2.2-8.el7, failed to reproduce.

Command line:
# /usr/libexec/qemu-kvm -net none -M pc -m 2G -cpu SandyBridge -smp 4,cores=2,threads=2,sockets=1 -monitor stdio -vnc :1 -drive file=/home/win2003-32-virtio.qcow2,if=none,id=guest-img -device ide-hd,drive=guest-img,id=os-disk -vga cirrus

Result:
Guest display normally(see attachment in this comment).

As the result above, I'd close this as dup of bug 979898.
Comment 10 Xu Han 2014-01-16 21:46:22 EST

*** This bug has been marked as a duplicate of bug 979898 ***

Note You need to log in before you can comment on or make changes to this bug.