Bug 1018758 - Non-working 32-bit flash-plugin supplied for x86_64.
Non-working 32-bit flash-plugin supplied for x86_64.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: flash-plugin (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 07:36 EDT by Eskil Brun
Modified: 2015-10-12 05:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 05:36:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eskil Brun 2013-10-14 07:36:32 EDT
Description of problem:
There is a flash-plugin.i686 distributed in rhel-x86_64-workstation-supplementary-6. This 32-bit plugin almost always fails on our x86_64 RHEL6 workstations. Adobe supplies a working 64-bit version. Could you please remove the non-working 32-bit flash-plugin from rhel-x86_64-workstation-supplementary-6 or supply the working 64-bit flash-plugin in rhel-x86_64-workstation-supplementary-6?

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:
1. Create a blank local user (this is necessary)
2. Install firefox, nspluginwrapper and flash-plugin
3. Log in as the newly created user and open this page with firefox: http://www.adobe.com/products/flash/about

Actual results:


When firefox loads flash content from http://www.adobe.com/products/flash/about the 32-bit flash-plugin is started by nspluginwrapper and the plugin crashes.

Expected results:

A working web page with flash content

Additional info:

Adobe now supplies a 64-bit flash-plugin rpm package with the same version as the 32-bit version supplied in rhel-x86_64-workstation-supplementary-6.

It is a bit odd that the flash-plugin has not been upgraded from a non-working 32-bit version to a working 64-bit version in rhel-x86_64-workstation-supplementary-6  

The same 64 bit version of flash-plugin from adobe works flawlessly.

Please update the flash-plugin in rhel-x86_64-workstation-supplementary-6 to a 64-bit version.
Comment 2 RHEL Product and Program Management 2013-10-14 21:23:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Martin Stransky 2015-10-12 05:36:32 EDT
We're not going to fix this one. If you want a working flash we need to ship 64-bit flash version.

Note You need to log in before you can comment on or make changes to this bug.