Bug 1018784 - [Doc Bug Fix] Incomplete list of RESTEasy Internally Thrown Exceptions
[Doc Bug Fix] Incomplete list of RESTEasy Internally Thrown Exceptions
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation, RESTEasy (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: EAP 6.4.2
Assigned To: Andrea Hoffer
Russell Dickenson
: Documentation, FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 08:04 EDT by Petr Sakař
Modified: 2015-07-17 08:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14875, Development Guide-6.2-1 Build Date: 02-10-2013 13:20:00 Topic ID: 2811-432841 [Latest]
Last Closed: 2015-07-16 16:35:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sakař 2013-10-14 08:04:42 EDT
Title: RESTEasy Internally Thrown Exceptions

Describe the issue:

I know about at least one case not mentioned - 406. Please consult with developers
Comment 6 Weinan Li 2015-07-16 11:49:35 EDT
In this document:   https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.4/html-single/Development_Guide/index.html#RESTEasy_Internally_Thrown_Exceptions

the description is complete for spi exceptions:

cute:resteasy-upstream-Branch_2_3 weli$ grep -rl 'Failure' * | grep java$ | grep -v test | grep 'Failure\|Exception' | grep spi
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/BadRequestException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/DefaultOptionsMethodException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/Failure.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/InternalServerErrorException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/LoggableFailure.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/MethodNotAllowedException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/NotAcceptableException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/NotFoundException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/ReaderException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/UnauthorizedException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/UnsupportedMediaTypeException.java
resteasy-jaxrs/src/main/java/org/jboss/resteasy/spi/WriterException.java

Other exceptions not included in document are not relative so I suggest this bug is fixed.
Comment 7 Andrea Hoffer 2015-07-16 16:35:31 EDT
Closing this as CLOSED - NOTABUG due to Weinan's response that the list is complete.

Note You need to log in before you can comment on or make changes to this bug.