Bug 1018803 - Not a very useful error on lvconvert from raid to thinpool
Not a very useful error on lvconvert from raid to thinpool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Zdenek Kabelac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 08:39 EDT by Nenad Peric
Modified: 2014-10-14 04:24 EDT (History)
9 users (show)

See Also:
Fixed In Version: lvm2-2.02.107-1.el6
Doc Type: Bug Fix
Doc Text:
no documentation required - error message improvements only
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:24:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1387 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2014-10-13 21:39:47 EDT

  None (edit)
Description Nenad Peric 2013-10-14 08:39:54 EDT
Description of problem:

When a RADI1 is converted to thinpool, device mapper spews an error, which is not fatal, but makes very little sense

How reproducible:

Everytime 

Steps to Reproduce:

[root@virt-013 ~]# vgcreate vg /dev/sd{a..f}1
  No physical volume label read from /dev/sdd1
  Physical volume /dev/sdd1 not found
  No physical volume label read from /dev/sdf1
  Physical volume /dev/sdf1 not found
  Physical volume "/dev/sdd1" successfully created
  Physical volume "/dev/sdf1" successfully created
  Volume group "vg" successfully created
[root@virt-013 ~]# lvcreate --type raid1 -L4G -n raid1 vg
  Logical volume "raid1" created
[root@virt-013 ~]# lvconvert --thinpool vg/raid1
  Logical volume "raid1_tmeta" created
  Logical volume "lvol0" created
  device-mapper: remove ioctl on  failed: Device or resource busy
  Converted vg/raid1 to thin pool.


Expected results:

Not seeing a message which looks as if something went wrong, when the conversion actually finished successfully. 


Additional info:

lvm2-2.02.100-5.el6.x86_64
device-mapper-1.02.79-5.el6.x86_64
Comment 1 Zdenek Kabelac 2013-10-14 08:48:01 EDT
This error message is related to deactivation of thin pool metadata spare device which is zeroed and deactivated - this should be handled in 2.02.102 via new udev rules flags.
Comment 3 RHEL Product and Program Management 2013-10-17 22:25:20 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Nenad Peric 2014-07-10 09:25:00 EDT
[root@virt-015 ~]# lvconvert --thinpool vg/raid1
  WARNING: Converting "vg/raid1" logical volume to pool's data volume.
  THIS WILL DESTROY CONTENT OF LOGICAL VOLUME (filesystem etc.)
Do you really want to convert "vg/raid1"? [y/n]: y
  Logical volume "raid1_tmeta" created
  Converted "vg/raid1" to thin pool.


[root@virt-015 ~]# lvconvert --thinpool vg/raid2 --yes
  WARNING: Converting "vg/raid2" logical volume to pool's data volume.
  THIS WILL DESTROY CONTENT OF LOGICAL VOLUME (filesystem etc.)
  Logical volume "raid2_tmeta" created
  Converted "vg/raid2" to thin pool.

marking VERIFIED with:

lvm2-2.02.107-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
lvm2-libs-2.02.107-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
lvm2-cluster-2.02.107-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
udev-147-2.55.el6    BUILT: Wed Jun 18 13:30:21 CEST 2014
device-mapper-1.02.86-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
device-mapper-libs-1.02.86-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
device-mapper-event-1.02.86-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
device-mapper-event-libs-1.02.86-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
device-mapper-persistent-data-0.3.2-1.el6    BUILT: Fri Apr  4 15:43:06 CEST 2014
cmirror-2.02.107-1.el6    BUILT: Mon Jun 23 16:44:45 CEST 2014
Comment 7 errata-xmlrpc 2014-10-14 04:24:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1387.html

Note You need to log in before you can comment on or make changes to this bug.