Bug 1018850 - Indefinite hang on plugin download
Indefinite hang on plugin download
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 10:14 EDT by Timothy St. Clair
Modified: 2013-10-17 05:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 12:58:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy St. Clair 2013-10-14 10:14:11 EDT
Description of problem:
The installation of the plugin driver for a LaserJet 100 color MFP M175nw just hangs trying to pull down the latest driver.  

Version-Release number of selected component (if applicable):
Name        : hplip
Arch        : x86_64
Version     : 3.13.9
Release     : 2.fc20

How reproducible:
100

Steps to Reproduce:
1. Try navigating through the setup wizard
2. On downloading of driver is always hangs

Actual results:
Hang

Expected results:
Successful installation

Additional info:
I've had no issues on f18 || f19.
Comment 1 Jiri Popelka 2013-10-14 11:14:22 EDT
Could you try to run the hp-plugin in debug mode, i.e. 'hp-plugin -i -g' and show me the output ?
Comment 2 Timothy St. Clair 2013-10-14 12:23:08 EDT
Seems to be locked on the following: 

---------------------------------------------
hp-plugin[19160]: debug: Downloading 3.13.9 plug-in file from 'http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run' to '/var/log/hp/tmp'...
hp-plugin[19160]: debug: /bin/wget --cache=off -P /var/log/hp/tmp http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run
hp-plugin[19160]: debug: --2013-10-14 11:18:45--  http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run
Resolving www.openprinting.org (www.openprinting.org)... 140.211.169.16
Connecting to www.openprinting.org (www.openprinting.org)|140.211.169.16|:80... 
hp-plugin[19160]: debug: failed: Connection timed out.
Retrying.


hp-plugin[19160]: debug: --2013-10-14 11:20:54--  (try: 2)  http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.13.9-plugin.run
Connecting to www.openprinting.org (www.openprinting.org)|140.211.169.16|:80... 
^Cerror: User exit

Done.
hp-plugin[19160]: debug: Unlocking: /var/hp-plugin.lock

---------------------------------------------

Trying to do regular connections to that url also fail.
Comment 3 Jiri Popelka 2013-10-14 12:58:37 EDT
(In reply to Timothy St. Clair from comment #2)
> Trying to do regular connections to that url also fail.

Nothing we can do here then.
Comment 4 Timothy St. Clair 2013-10-15 14:06:29 EDT
Of note:  The site appears to be back up today, and the installation worked fine.  

It may be a prudent measure to open an upstream ticket to give a meaningful error message to the user.

Note You need to log in before you can comment on or make changes to this bug.