Bug 1018855 - Don't complied to PHP Guidelines
Don't complied to PHP Guidelines
Status: CLOSED DUPLICATE of bug 1014353
Product: Fedora
Classification: Fedora
Component: php-lightopenid (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Patrick Uiterwijk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 10:24 EDT by Remi Collet
Modified: 2013-10-14 11:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 11:09:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2013-10-14 10:24:24 EDT
Same comments as in package review.

[!]: Package complies to the Packaging Guidelines

Please read: http://fedoraproject.org/wiki/Packaging:PHP

Requires:       php >= 5.1.2

=> A PHP library must not have an explicit Requires on php or httpd..

From phpcompatinfo report should be

Requires:       php(language) >= 5.1.2 (but this one have no interest)
Requires:       php-curl
Requires:       php-pcre

%{_datadir}/lightopenid

=> Non-PEAR PHP software which provides shared libraries should put its PHP source files for such shared libraries in a subfolder of /usr/share/php
Comment 1 Patrick Uiterwijk 2013-10-14 11:09:49 EDT

*** This bug has been marked as a duplicate of bug 1014353 ***

Note You need to log in before you can comment on or make changes to this bug.