Bug 1018860 - Installer hangs if SSL enabled
Installer hangs if SSL enabled
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
high Severity urgent
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Pavel Drozd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 10:31 EDT by Pavol Srna
Modified: 2014-02-06 10:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installer-jstack (15.64 KB, text/plain)
2013-10-14 10:32 EDT, Pavol Srna
no flags Details
runtime-jstack (121.01 KB, text/plain)
2013-10-14 10:32 EDT, Pavol Srna
no flags Details
screenshot (148.88 KB, image/png)
2013-10-14 10:33 EDT, Pavol Srna
no flags Details
win-screenshot (43.41 KB, image/png)
2013-10-15 09:46 EDT, Pavol Srna
no flags Details
logs-rhel (26.45 KB, application/zip)
2013-10-15 10:36 EDT, Pavol Srna
no flags Details
logs-win (31.70 KB, application/zip)
2013-10-15 10:36 EDT, Pavol Srna
no flags Details

  None (edit)
Description Pavol Srna 2013-10-14 10:31:48 EDT
Description of problem:

Installer hangs if SSL is enabled. 
Please find screenshot and jstack attached.
Comment 1 Pavol Srna 2013-10-14 10:32:29 EDT
Created attachment 812039 [details]
installer-jstack
Comment 2 Pavol Srna 2013-10-14 10:32:53 EDT
Created attachment 812040 [details]
runtime-jstack
Comment 3 Pavol Srna 2013-10-14 10:33:21 EDT
Created attachment 812041 [details]
screenshot
Comment 4 Pavol Srna 2013-10-14 10:34:29 EDT
Tried with ER4-respin 3 installer from 11-Oct-2013 08:23
Comment 6 Pavol Srna 2013-10-15 09:45:59 EDT
Installer doesn't hang on windows (in opposite to RHEL), but there is a "Failed to connect to Management Interface after 5 attempts" message (see screenshot attached) and the installers says "Installation successfully completed" at the end.
Comment 7 Pavol Srna 2013-10-15 09:46:27 EDT
Created attachment 812539 [details]
win-screenshot
Comment 8 Pavol Srna 2013-10-15 10:36:17 EDT
Created attachment 812560 [details]
logs-rhel
Comment 9 Pavol Srna 2013-10-15 10:36:48 EDT
Created attachment 812561 [details]
logs-win
Comment 10 Thomas Hauser 2013-10-15 10:56:14 EDT
This issue is due to the CommandContext API writing a prompt to the user.
Comment 11 Thomas Hauser 2013-10-18 15:08:08 EDT
This issue is due to the CommandContext blocking on user input:

https://community.jboss.org/thread/212065

It has been worked around by enabling SSL security later in the installation process, so the installer doesn't try to connect with the SSL security running (the CommandContext would then block on user input at that point). This should probably be addressed in the CommandContext itself (provide some way to programmatically provide a Temporary SSL acceptance response, or to optionally not block on user input, something along those lines. 

This issue is resolved in post-beta builds, whatever ER or designation that may be.
Comment 12 Anne-Louise Tangring 2013-10-22 09:42:50 EDT
Not a beta blocker.
Comment 13 Pavol Srna 2013-12-13 08:25:45 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.