Bug 1018891 - Package Request for EPEL 6: i3 (and XCB)
Package Request for EPEL 6: i3 (and XCB)
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: i3 (Show other bugs)
el6
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Simon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 11:46 EDT by kyle.strand
Modified: 2013-10-14 13:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 12:58:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kyle.strand 2013-10-14 11:46:48 EDT
Description of problem: 

The version of the i3 window manager in the EPEL repo is 4.0.1, which was compiled in 2011. I need a newer version, but have been told 
that newer versions of i3 have a dependency on XCB packages that is not
satisfied in the EPEL repo
(https://lists.fedoraproject.org/pipermail/epel-devel/2013-October/008804.html).
Could someone please add the necessary XCB packages and update i3?


Version-Release number of selected component (if applicable): N/A, I think
Comment 1 Simon 2013-10-14 12:58:56 EDT
If you need a newer version, you have to compile the dependencies and i3 for yourself.

It's not a problem to add missing dependencies. But there are some dependencies in the "core"-repository, which are too old and need to be updated to provide an update for i3. There is the problem. EPEL stands for "Extra Packages for Enterprise Linux". So the goal of EPEL is to provide packages which are helpful and popular, but are not a part of EL and won't be in conflict with packages in EL. In this fact, we (in EPEL) can't provide updates for EL and we never will be. This is a no-go, because this is too dangerous and would risk the stability of the EL. 

Read:
http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#Digest
http://code.stapelberg.de/git/i3/tree/DEPENDS

4.0.2 is the latest possible version of i3 in epel. It's not possible to update it to 4.1 or higher, sorry...
Comment 2 kyle.strand 2013-10-14 13:05:35 EDT
Well, that's unfortunate, and I guess I'll try to compile those myself when I get a chance, but even updating to 4.0.2 would fix an extremely aggravating Chrome bug.
Comment 3 kyle.strand 2013-10-14 13:14:49 EDT
(In reply to Simon from comment #1)
> In this fact, we (in EPEL) can't provide
> updates for EL and we never will be. This is a no-go, because this is too
> dangerous and would risk the stability of the EL. 

Can I request an update to the core EL packages that are in conflict?

> 4.0.2 is the latest possible version of i3 in epel. It's not possible to
> update it to 4.1 or higher, sorry...

Could the package be updated to 4.0.2, then? I know of at least one irritating bug that was fixed in this version.

Note You need to log in before you can comment on or make changes to this bug.