Bug 1018967 - Inconsistency in package installation status
Inconsistency in package installation status
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 15:46 EDT by Zdenek Chmelar
Modified: 2013-11-01 07:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 07:02:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
meld displayed as ready for installation (even if installed) (67.25 KB, image/png)
2013-10-14 15:46 EDT, Zdenek Chmelar
no flags Details
Meld displayed correctly - with remove button (30.88 KB, image/png)
2013-10-14 15:47 EDT, Zdenek Chmelar
no flags Details

  None (edit)
Description Zdenek Chmelar 2013-10-14 15:46:13 EDT
Created attachment 812210 [details]
meld displayed as ready for installation (even if installed)

Description of problem:
Gnome-software shows some packages as ready for installation even if they are installed

Version-Release number of selected component (if applicable):
gnome-software-3.10.0-1.fc20.x86_64

How reproducible:
depends on what's searched 

Steps to Reproduce:
1. open gnome-application
2. search for 'gnome' to find all applicable packages
3. result shows some applications available for installation even if they are already installed

Actual results:
Installed applications have button 'Install' in search result

Expected results:
Installed application should have button 'Remove'

Additional info:
1. If I search exact application with its name (e.g. not general search like 'gnome' but 'meld'), search result shows this application with correct button 'remove'

2. Please see attached screenshots for better understanding of this bug:

Application Meld is installed on my PC
a) search result of word 'gnome' shows meld available for installation
b) search result of word 'meld' shows meld ready for removal

3. If I click on 'Install' button, it looks like the installation is initiated but ends quickly (without gnome-software crash or any other error) and application is still listed with button 'Install'
Comment 1 Zdenek Chmelar 2013-10-14 15:47:07 EDT
Created attachment 812211 [details]
Meld displayed correctly - with remove button
Comment 2 Zdenek Chmelar 2013-10-14 15:56:37 EDT
I tried with other application (Archive manager) that's installed on my laptop (e.g. is listed in gnome-software under 'installed' applications with remove button).
When I search for 'Archive manager', result contains Archive manager application with 'Install' button (e.g. could be installed)
When I search for 'Archive' only, result returned Archive manager with remove button (e.g. as already installed)
Comment 4 Zdenek Chmelar 2013-11-01 07:02:08 EDT
I can confirm this bug is fixed with current version of gnome-software (3.10.3-1). Ticket can be closed. Thank you!

Note You need to log in before you can comment on or make changes to this bug.