Bug 1019026 - RBAC: Incorrect permission metadata for server group scoped roles on server-config=* resource
RBAC: Incorrect permission metadata for server group scoped roles on server-c...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: EAP 6.2.0
Assigned To: Brian Stansberry
Ladislav Thon
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 22:38 EDT by Brian Stansberry
Modified: 2013-12-15 11:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Causes: Consequence: Workaround (if any): Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:13:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Stansberry 2013-10-14 22:38:07 EDT
The permissons are wrong for server group scoped roles:

/host=master/server-config=*
    read-config:true
    write-config:false

With these settings a SGSR cannot add new server configurations, even for the group it's assigned to.


This is because the HostServerGroupTracker interprets the '*' as a normal server group name.
Comment 2 Ladislav Thon 2013-11-06 06:38:40 EST
Verified with EAP 6.2.0.ER7.

Note You need to log in before you can comment on or make changes to this bug.