This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019044 - Packstack ignores neutron physical network configuration if CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=gre
Packstack ignores neutron physical network configuration if CONFIG_NEUTRON_OV...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity high
: rc
: 4.0
Assigned To: Terry Wilson
Ofer Blaut
: Reopened
Depends On:
Blocks: 1039140
  Show dependency treegraph
 
Reported: 2013-10-15 00:37 EDT by Ofer Blaut
Modified: 2013-12-19 19:27 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Packstack now supports answer file specifications for physical networks, VLANs, and bridge mappings; when configuring tenant networking with GRE tunnels.
Story Points: ---
Clone Of:
: 1039140 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:27:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1006534 None None None Never

  None (edit)
Description Ofer Blaut 2013-10-15 00:37:14 EDT
Description of problem:

My answer file includes the following:

CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=gre
CONFIG_NEUTRON_OVS_VLAN_RANGES=physnet1
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-eth1
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-eth1:eth1
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=1:1000

My intent is to use GRE tunnels for tenant networks, but use a VLAN on eth1 for my external network.

The installation completed, and configuration for the tenant GRE tunnels looks correct, but the configuration for the physical network was ignored.


Version-Release number of selected component (if applicable):

openstack-packstack.noarch       2013.2.1-0.9.dev756.el6       @openstack-havana


How reproducible:

every time


Steps to Reproduce:
1. Run packstack with options above
2. Examine configuration for server and agents
3. Try to create a provider network using physnet1

Actual results:

On the server node, /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini does not contain network_vlan_ranges.

On the nodes where neutron-openvswitch-agent runs, /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini does not contain bridge_mappings, and br-eth1 has not been created.

Provider external network cannot be created because physnet1 is not known.


Expected results:

On the server node, /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini should contain: "network_vlan_ranges = physnet1".

On the nodes where neutron-openvswitch-agent runs, /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini should contain "bridge_mappings=physnet1:br-eth1", and the br-eth1 OVS bridge should be created with eth1 added as a port.


Additional info:

N/A
Comment 1 Martin Magr 2013-10-29 11:29:22 EDT
CONFIG_NEUTRON_OVS_VLAN_RANGES, CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS and CONFIG_NEUTRON_OVS_BRIDGE_IFACES parameters are filled only if CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=vlan so actually this is a feature.
Comment 2 Bob Kukura 2013-10-30 06:43:45 EDT
This is a bug, not a feature. All network types can be used for provider networks (including provider external networks), regardless of which network type is selected for tenant networks. Using vlan or flat provider networks still requires network_vlan_ranges and bridge_mappings to be set. So these packstack config items need to work normally even when CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE is not 'vlan'.

Also, this bug looks like a copy/clone of https://bugzilla.redhat.com/show_bug.cgi?id=1006534, which I filed originally against RDO, and is currently being worked on.

-Bob
Comment 3 Alvaro Lopez Ortega 2013-11-15 07:38:07 EST
AFAIK, Terry is already working on the RDO's version of the bug.
Comment 4 Alvaro Lopez Ortega 2013-12-03 12:50:11 EST
A patch for this was already merged ~10 days ago.
Comment 7 Ofer Blaut 2013-12-08 06:16:56 EST
tested, seems working fine openstack-packstack-2013.2.1-0.13.dev876.el6ost.noarch




[OVS]
network_vlan_ranges=inter-vlan:195:203
local_ip=55.55.55.19
enable_tunneling=True
integration_bridge=br-int
tunnel_id_ranges=1:1000
tunnel_bridge=br-tun
tenant_network_type=gre
bridge_mappings=inter-vlan:br-eth3
Comment 9 Bob Kukura 2013-12-12 12:20:49 EST
Slight clarification to the doc text.
Comment 11 errata-xmlrpc 2013-12-19 19:27:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.