Bug 101905 - getty/panic when using USB to RS232 converter
getty/panic when using USB to RS232 converter
Status: CLOSED DUPLICATE of bug 90442
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 17:37 EDT by Colin Rudakiewicz
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Rudakiewicz 2003-08-07 17:37:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have a USB to RS232 converter, with a 3COM U.S. Robotics 56K Fax modem. I am
able to cu -l /dev/usb/ttyUSB0 and dial out successfully, however when enabling
agetty/mingetty on /dev/usb/ttyUSB0 the system panics. 

There are four LEDs on my modem, RD (Receive data), SD (Send Data), PWR (Power)
and CD (Carrier Detect). Just prior to the panic the RD/SD LED's blink fast. 

Have tried the following perferations in /etc/inittab:

7:2345:respawn:/sbin/mingetty usb/ttyUSB0

7:2345:respawn:/sbin/agetty -h -t60 -w -I 'ATF0S0=1\015' 9600 usb/ttyUSB0

7:2345:respawn:/sbin/agetty -L 9600 usb/ttyUSB0

All perferations result in a panic.

Panic stack trace:

[<c01cd9d0>] ide_dma_intr [kernel] 0x0 (0xc0349e68))
[<d8044aad>] uhci_clean_transfer [usb_uhci] 0x11d (0xc0349e88))
[<d804694f>] process_interrupt [usb_uhci] 0x20f (0xc0349ecc))
[<d8046d50>] process_urb [usb_uhci] 0x250 (0xc0349ef0))
[<c01830a2>] flush_to_ldisc [kernel] 0xc2 (0xc0349f04))
[<c01213fd>] __run_task_queue [kernel] 0x4d (0xc0349f20))
[<c0124daf>] tqueue_bh [kernel] 0x1f (0xc0349f38))
[<c0121342>] bh_action [kernel] 0x22 (0xc0349f40))
[<c0121256>] tasklet_hi_action [kernel] 0x46 (0xc0349f44))
[<c0121094>] do_softirq [kernel] 0x94 (0xc0349f50))
[<c010aa9f>] do_IRQ [kernel] 0xaf (0xc0349f68))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349f78))
[<c010d498>] call_do_IRQ [kernel] 0x5 (0xc0349f88))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349f8c)
[<c0106ec3>] default_idle [kernel] 0x23 (0xc0349fb4))
[<c011564f>] apm_cpu_idle [kernel] 0x9f (0xc0349fc0))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349fc4))
[<c0106f35>] cpu_idle [kernel] 0x35 (0xc0349fd4))
[<c0105000>] stext [kernel] 0x0 (0xc0349fe0))

Code: 0f 0b e7 03 df 9c 25 c0 e9 69 fd ff ff 89 f6 8d bc 27 00 00

 <0>Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing


And another,

[<c02091d0>] ip_forward_finish [kernel] 0x0 (0xc0349e44))
[<c0184737>] n_tty_receive_buf [kernel] 0x237 (0xc0349e5c))
[<d8044aad>] uhci_clean_transfer [usb_uhci] 0x11d (0xc0349e88))
[<d804694f>] process_interrupt [usb_uhci] 0x20f (0xc0349ecc))
[<d8046d50>] process_urb [usb_uhci] 0x250 (0xc0349ef0))
[<c01830a2>] flush_to_ldisc [kernel] 0xc2 (0xc0349f04))
[<c01213fd>] __run_task_queue [kernel] 0x4d (0xc0349f20))
[<c0124daf>] tqueue_bh [kernel] 0x1f (0xc0349f38))
[<c0121342>] bh_action [kernel] 0x22 (0xc0349f40))
[<c0121256>] tasklet_hi_action [kernel] 0x46 (0xc0349f44))
[<c0121094>] do_softirq [kernel] 0x94 (0xc0349f50))
[<c010aa9f>] do_IRQ [kernel] 0xaf (0xc0349f68))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349f78))
[<c010d498>] call_do_IRQ [kernel] 0x5 (0xc0349f88))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349f8c)
[<c0106ec3>] default_idle [kernel] 0x23 (0xc0349fb4))
[<c011564f>] apm_cpu_idle [kernel] 0x9f (0xc0349fc0))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349fc4))
[<c0106f35>] cpu_idle [kernel] 0x35 (0xc0349fd4))
[<c0105000>] stext [kernel] 0x0 (0xc0349fe0))

Code: 0f 0b e7 03 df 9c 25 c0 e9 69 fd ff ff 89 f6 8d bc 27 00 00

 <0>Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing

Version-Release number of selected component (if applicable):
Red Hat Linux (2.4.20-19.9), Linux release 9 (Shrike)

How reproducible:
Always

Steps to Reproduce:
7:2345:respawn:/sbin/mingetty usb/ttyUSB0

7:2345:respawn:/sbin/agetty -h -t60 -w -I 'ATF0S0=1\015' 9600 usb/ttyUSB0

7:2345:respawn:/sbin/agetty -L 9600 usb/ttyUSB0

Actual Results:  panic

Expected Results:  Should provide a login for dialin access

Additional info:

uucp-1.06.1-47
mingetty-1.0-1
2.4.20-19.9 (i686)
util-linux-2.11y-9
dev-3.3.2-5
libusb-devel-0.1.6-3
usbutils-0.9-10
libusb-0.1.6-3
Comment 1 Pete Zaitcev 2003-08-07 18:54:58 EDT
Can you get me the top of the trace too?
A serial console is probably the best way.
Comment 2 Colin Rudakiewicz 2003-08-08 08:17:43 EDT
Hi Zaitcev,

I will purchase a null modem cable, configure grub to redirect my console 
to /dev/ttyS0, I will then use Hyper Term to connect my PC to the server serial 
port. This will take a little while; I am currently at work and the affected 
machine is at home... 

Is there a way to tune the kernel so that it will save the dump to disk..? If 
so I can then place the dump/kernel/modules on an ftp server for you to 
download...

Regards - Colin Rudakiewicz

Comment 3 Pete Zaitcev 2003-08-08 12:41:55 EDT
Red Het Enterprise Linux ships with netconsole support, but I forget now
if RHL does it too. It's Ingo Molnar's patch which does console over Ethernet.
 http://www.redhat.com/support/wpapers/redhat/netdump/index.html
Serial was always easier for me, that's why I mentioned it.
Comment 4 Colin Rudakiewicz 2003-08-08 15:24:15 EDT
Hi Pete,

The null modem cable did the trick, the requested output follows:


------------[ cut here ]------------
kernel BUG at sched.c:999!
invalid operand: 0000
ipt_MASQUERADE iptable_nat ip_conntrack parport_pc lp parport autofs 3c59x 
e1000
 tulip ipt_REJECT iptable_filter ip_tables mct_u232 usbserial keybdev mousedev
CPU:    0
EIP:    0060:[<c01187fa>]    Not tainted
EFLAGS: 00010202

EIP is at schedule [kernel] 0x2aa (2.4.20-19.9)
eax: 00000001   ebx: c1ca2874   ecx: c0349dc4   edx: c0349dbc
esi: c0348000   edi: c1ca287c   ebp: c0349db4   esp: c0349da4
ds: 0068   es: 0068   ss: 0068
Process swapper (pid: 0, stackpage=c0349000)
Stack: 00000000 c1ca2874 c0348000 c1ca287c c0349dbc c01081ff 00000001 c0348000
       c1ca287c c1ca287c c1ca281c c1ca2874 c1ca2800 ffffffea c0108354 c1ca2874
       c1ca2800 ffffffed d82529d3 c1ca281c d8252b68 00000000 d644c000 00000010
Call Trace:   [<c01081ff>] __down [kernel] 0x5f (0xc0349db8))
[<c0108354>] __down_failed [kernel] 0x8 (0xc0349ddc))
[<d82529d3>] .text.lock.usbserial [usbserial] 0x41 (0xc0349dec))
[<d8252b68>] .rodata.str1.1 [usbserial] 0xfa (0xc0349df4))
[<c0183c92>] opost [kernel] 0x22 (0xc0349e0c))
[<c0185879>] n_tty_receive_char [kernel] 0x159 (0xc0349e34))
[<c0207b0d>] ip_local_deliver [kernel] 0x4d (0xc0349e44))
[<c0184737>] n_tty_receive_buf [kernel] 0x237 (0xc0349e5c))
[<d8044aad>] uhci_clean_transfer [usb-uhci] 0x11d (0xc0349e88))
[<d804694f>] process_interrupt [usb-uhci] 0x20f (0xc0349ecc))
[<d8046d50>] process_urb [usb-uhci] 0x250 (0xc0349ef0))
[<c01830a2>] flush_to_ldisc [kernel] 0xc2 (0xc0349f04))
[<c01213fd>] __run_task_queue [kernel] 0x4d (0xc0349f20))
[<c0124daf>] tqueue_bh [kernel] 0x1f (0xc0349f38))
[<c0121342>] bh_action [kernel] 0x22 (0xc0349f40))
[<c0121256>] tasklet_hi_action [kernel] 0x46 (0xc0349f44))
[<c0121094>] do_softirq [kernel] 0x94 (0xc0349f50))
[<c010aa8f>] do_IRQ [kernel] 0xaf (0xc0349f68))
[<c010d498>] call_do_IRQ [kernel] 0x5 (0xc0349f88))
[<c0106ec3>] default_idle [kernel] 0x23 (0xc0349fb4))
[<c011564f>] apm_cpu_idle [kernel] 0x9f (0xc0349fc0))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349fc4))
[<c0106f35>] cpu_idle [kernel] 0x35 (0xc0349fd4))
[<c0105000>] stext [kernel] 0x0 (0xc0349fe0))


Code: 0f 0b e7 03 df 9c 25 c0 e9 69 fd ff ff 89 f6 8d bc 27 00 00
 <0>Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing




And another,


------------[ cut here ]------------
kernel BUG at sched.c:999!
invalid operand: 0000
ipt_MASQUERADE iptable_nat ip_conntrack parport_pc lp parport autofs 3c59x 
e1000
 tulip ipt_REJECT iptable_filter ip_tables mct_u232 usbserial keybdev mousedev
CPU:    0
EIP:    0060:[<c01187fa>]    Not tainted
EFLAGS: 00010202

EIP is at schedule [kernel] 0x2aa (2.4.20-19.9)
eax: 00000001   ebx: d6211474   ecx: c0349dc4   edx: c0349dbc
esi: c0348000   edi: d621147c   ebp: c0349db4   esp: c0349da4
ds: 0068   es: 0068   ss: 0068
Process swapper (pid: 0, stackpage=c0349000)
Stack: 00000004 d6211474 c0348000 d621147c c0349dbc c01081ff 00000001 c0348000
       d621147c d621147c d621141c d6211474 d6211400 ffffffea c0108354 d6211474
       d6211400 ffffffed d805c9d3 d621141c d805cb68 c01f9283 d1a45000 00000010
Call Trace:   [<c01081ff>] __down [kernel] 0x5f (0xc0349db8))
[<c0108354>] __down_failed [kernel] 0x8 (0xc0349ddc))
[<d805c9d3>] .text.lock.usbserial [usbserial] 0x41 (0xc0349dec))
[<d805cb68>] .rodata.str1.1 [usbserial] 0xfa (0xc0349df4))
[<c01f9283>] nf_hook_slow [kernel] 0xb3 (0xc0349df8))
[<c0183c92>] opost [kernel] 0x22 (0xc0349e0c))
[<c02091d0>] ip_forward_finish [kernel] 0x0 (0xc0349e14))
[<c0185879>] n_tty_receive_char [kernel] 0x159 (0xc0349e34))
[<c02091d0>] ip_forward_finish [kernel] 0x0 (0xc0349e44))
[<c0184737>] n_tty_receive_buf [kernel] 0x237 (0xc0349e5c))
[<d8044aad>] uhci_clean_transfer [usb-uhci] 0x11d (0xc0349e88))
[<d804694f>] process_interrupt [usb-uhci] 0x20f (0xc0349ecc))
[<d8046d50>] process_urb [usb-uhci] 0x250 (0xc0349ef0))
[<c01830a2>] flush_to_ldisc [kernel] 0xc2 (0xc0349f04))
[<c01213fd>] __run_task_queue [kernel] 0x4d (0xc0349f20))
[<c0124daf>] tqueue_bh [kernel] 0x1f (0xc0349f38))
[<c0121342>] bh_action [kernel] 0x22 (0xc0349f40))
[<c0121256>] tasklet_hi_action [kernel] 0x46 (0xc0349f44))
[<c0121094>] do_softirq [kernel] 0x94 (0xc0349f50))
[<c010aa8f>] do_IRQ [kernel] 0xaf (0xc0349f68))
[<c010d498>] call_do_IRQ [kernel] 0x5 (0xc0349f88))
[<c0106ec3>] default_idle [kernel] 0x23 (0xc0349fb4))
[<c011564f>] apm_cpu_idle [kernel] 0x9f (0xc0349fc0))
[<c01155b0>] apm_cpu_idle [kernel] 0x0 (0xc0349fc4))
[<c0106f35>] cpu_idle [kernel] 0x35 (0xc0349fd4))
[<c0105000>] stext [kernel] 0x0 (0xc0349fe0))


Code: 0f 0b e7 03 df 9c 25 c0 e9 69 fd ff ff 89 f6 8d bc 27 00 00
 <0>Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing
Comment 5 Pete Zaitcev 2003-08-08 15:52:18 EDT
How unfortunate. Now I recognise the symptom - it's a close relative
of bug 90442 (please don't dup yet). The proper fix would require significant
rework of usbserial.c. Perhaps I can plug around it by fiddling with
the low latency flags in a partucular sub-module...

Please attach a /proc/bus/usb/devices snapshot.
Comment 6 Colin Rudakiewicz 2003-08-08 16:12:09 EDT
Hi Pete,

Many thanks for your continued support.

cat /proc/bus/usb/devices gives,

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc= 72/900 us ( 8%), #Int=  2, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=c800
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0711 ProdID=0230 Rev= 1.02
S:  Manufacturer=USB-RS232 Interface Converter
S:  Product=USB Ver1.1 Device
S:  SerialNumber=084033
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=serial
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=2ms
E:  Ad=82(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  16 Ivl=0ms
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=c400
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms

Rgds Colin
Comment 7 Pete Zaitcev 2003-11-15 21:32:27 EST
Duping to 90442 - there's a patch there, which might help.


*** This bug has been marked as a duplicate of 90442 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:58:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.