Bug 101911 - klipperrc config file not LSB-compliant
klipperrc config file not LSB-compliant
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kdebase (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 18:34 EDT by Chris Ricker
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 10:21:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-08-07 18:34:37 EDT
I got this when upgrading from RHL 9 to severn beta1:

warning: /usr/share/config/klipperrc saved as /usr/share/config/klipperrc.rpmsave

That config file needs to be in /etc, not in /usr....
Comment 1 Ngo Than 2003-08-11 08:17:46 EDT
no, kde config files are default installed in /us/share/config, not in /etc.

Comment 2 Chris Ricker 2003-08-11 09:19:10 EDT
Right, and that needs to be fixed. It's incompatible with the LSB.

See:

http://www.linuxbase.org/spec/refspecs/LSB_1.3.0/gLSB/gLSB/execenvfhs.html
"An LSB conforming implementation must adhere to the FHS 2.2."

So, if we look at the FHS 2.2,

http://www.pathname.com/fhs/2.2/fhs-4.11.html
"The /usr/share hierarchy is for all read-only architecture independent data files."

Nothing goes in /usr/share which is modified. It has to be read-only (think
things like clusters sharing /usr over NFS). Instead anything which gets
modified goes under /etc:

http://www.pathname.com/fhs/2.2/fhs-3.7.html
"/etc contains configuration files and directories that are specific to the
current system."

This may be KDE's default, but it is broken because it is noncompliant with the
LSB, and it does cause problems for people with read-only /usr

Comment 3 Ngo Than 2003-08-11 10:21:27 EDT
Hm, the files in /usr/share/config are the global default config files, which
are architecture independent data files. And off course, nothing should be
modified here. It's correct that they are installed in /usr/share/config. if
someone makes change in KDE, they will be saved in $HOME/.kde/share.

I don't see it's a bug here.

Note You need to log in before you can comment on or make changes to this bug.