Bug 1019114 - After updating to 1.11.3-24.fc20, google account is rejected in gnome-online-accounts
After updating to 1.11.3-24.fc20, google account is rejected in gnome-online-...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 03:54 EDT by sangu
Modified: 2013-10-15 13:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 12:51:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2013-10-15 03:54:39 EDT
Description of problem:

$ journactl --user -b 
10월 15 16:20:46 localhost gnome-session[1272]: (process:2173): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
10월 15 16:23:23 localhost gnome-session[1272]: 16:23:23.431:[2307]:[DEBUG]: Stored keyring credentials for identity: account_1362617327 [goautils.c:326, goa_utils_store_credentials_for_id_sync()]
10월 15 16:23:23 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:23:47 localhost gnome-session[1272]: 16:23:47.280:[2307]:[DEBUG]: Stored keyring credentials for identity: account_1362617327 [goautils.c:326, goa_utils_store_credentials_for_id_sync()]
10월 15 16:23:47 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:29:35 localhost gnome-session[1272]: 16:29:35.456:[2307]:[DEBUG]: Stored keyring credentials for identity: account_1362617327 [goautils.c:326, goa_utils_store_credentials_for_id_sync()]
10월 15 16:29:35 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:30:58 localhost gnome-session[1272]: tp-account-widgets-Message: tpaw_connection_managers_update
10월 15 16:30:59 localhost gnome-session[1272]: tp-account-widgets-Message: tpaw_connection_managers_listed_cb
10월 15 16:31:18 localhost goa[1393]: secret_password_store_sync() failed: The secret was transferred or encrypted in an invalid way. [goautils.c:317, goa_utils_store_credentials_for_id_sync()]
10월 15 16:31:18 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:31:18 localhost goa[1393]: /org/gnome/OnlineAccounts/Accounts/account_1381822277_0: Setting AttentionNeeded to TRUE because EnsureCredentials() failed with: No credentials found in ...edentials_cb()]
10월 15 16:31:30 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:31:37 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:31:40 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:31:44 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:31:49 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]
10월 15 16:31:52 localhost goa[1393]: secret_password_lookup_sync() returned NULL [goautils.c:244, goa_utils_lookup_credentials_sync()]


Version-Release number of selected component (if applicable):
1.11.3-24.fc20

How reproducible:
always

Steps to Reproduce:
1. update to 1.11.3-24.fc20
2. reboot
3. add google account in gnome-control-center online-accounts

Actual results:


Expected results:


Additional info:
This issue does not happen in krb5-libs-1.11.3-21.fc20.x86_64.

gnome-online-accounts-3.10.0-2.fc20.x86_64
control-center-3.10.0-1.fc20.x86_64
Comment 1 Nalin Dahyabhai 2013-10-15 11:39:26 EDT
Is that the only package that differs between this and the broken case?  For reference, which versions of keyutils and the kernel packages are you using?
Comment 2 sangu 2013-10-15 12:34:00 EDT
(In reply to Nalin Dahyabhai from comment #1)
> Is that the only package that differs between this and the broken case?
/var/log/yum.log
[...]
Oct 15 15:34:15 Updated: openldap-2.4.36-2.fc20.x86_64
Oct 15 15:34:16 Updated: libsss_idmap-1.11.1-3.fc20.x86_64
Oct 15 15:34:17 Updated: pulseaudio-libs-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:18 Updated: pam-1.1.8-1.fc20.x86_64
Oct 15 15:34:19 Updated: 2:libwbclient-4.1.0-1.fc20.x86_64
Oct 15 15:34:20 Updated: 2:samba-libs-4.1.0-1.fc20.x86_64
Oct 15 15:34:21 Updated: 2:samba-common-4.1.0-1.fc20.x86_64
Oct 15 15:34:22 Updated: pulseaudio-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:23 Updated: dracut-034-8.git20131008.fc20.x86_64
Oct 15 15:34:23 Updated: 2:libsmbclient-4.1.0-1.fc20.x86_64
Oct 15 15:34:24 Updated: sssd-client-1.11.1-3.fc20.x86_64
Oct 15 15:34:25 Updated: sssd-common-1.11.1-3.fc20.x86_64
Oct 15 15:34:25 Updated: sssd-krb5-common-1.11.1-3.fc20.x86_64
Oct 15 15:34:26 Updated: sssd-common-pac-1.11.1-3.fc20.x86_64
Oct 15 15:34:26 Updated: sssd-ad-1.11.1-3.fc20.x86_64
Oct 15 15:34:27 Updated: sssd-krb5-1.11.1-3.fc20.x86_64
Oct 15 15:34:27 Updated: sssd-ldap-1.11.1-3.fc20.x86_64
Oct 15 15:34:28 Updated: sssd-proxy-1.11.1-3.fc20.x86_64
Oct 15 15:34:28 Updated: pulseaudio-utils-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:29 Updated: libipa_hbac-1.11.1-3.fc20.x86_64
Oct 15 15:34:29 Updated: sssd-ipa-1.11.1-3.fc20.x86_64
Oct 15 15:34:30 Updated: python-sssdconfig-1.11.1-3.fc20.noarch
Oct 15 15:34:30 Updated: sssd-1.11.1-3.fc20.x86_64
Oct 15 15:34:31 Updated: pulseaudio-module-x11-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:31 Updated: 2:samba-client-4.1.0-1.fc20.x86_64
Oct 15 15:34:32 Updated: dracut-network-034-8.git20131008.fc20.x86_64
Oct 15 15:34:32 Updated: dracut-config-rescue-034-8.git20131008.fc20.x86_64
Oct 15 15:34:32 Updated: pulseaudio-module-bluetooth-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:33 Updated: 2:samba-4.1.0-1.fc20.x86_64
Oct 15 15:34:34 Updated: pulseaudio-libs-glib2-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:34 Updated: gstreamer-tools-0.10.36-6.fc20.x86_64
Oct 15 15:34:34 Updated: pulseaudio-gdm-hooks-4.0-7.gitf81e3.fc20.x86_64
Oct 15 15:34:35 Updated: gstreamer-plugins-base-0.10.36-6.fc20.x86_64
Oct 15 15:39:43 Updated: krb5-libs-1.11.3-24.fc20.x86_64
Oct 15 15:39:44 Updated: 1:openssl-libs-1.0.1e-27.fc20.x86_64
Oct 15 15:39:49 Installed: kernel-3.11.5-300.fc20.x86_64
Oct 15 15:39:49 Updated: kernel-tools-libs-3.11.5-300.fc20.x86_64
Oct 15 15:39:50 Updated: kernel-tools-3.11.5-300.fc20.x86_64
Oct 15 15:39:51 Installed: kernel-modules-extra-3.11.5-300.fc20.x86_64
Oct 15 15:39:51 Updated: 1:openssl-1.0.1e-27.fc20.x86_64
Oct 15 15:39:53 Updated: kernel-headers-3.11.5-300.fc20.x86_64
Oct 15 15:39:53 Updated: libchewing-0.3.5-1.fc20.x86_64

> For reference, which versions of keyutils and the kernel packages are you using?
keyutils-1.5.8-1.fc20.x86_64
kernel-3.11.5-300.fc20.x86_64
Comment 3 sangu 2013-10-15 12:51:20 EDT
After updating to 1.11.3-24 for testing again, reboot.
Then, this issue doesn't happen.

Sorry about wrong report.
Comment 4 Nalin Dahyabhai 2013-10-15 13:01:00 EDT
No worries.  Thanks for taking the closer look.

Note You need to log in before you can comment on or make changes to this bug.