Bug 1019234 - jersey: FTBFS in rawhide
jersey: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jersey (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: gil cattaneo
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 06:47 EDT by Mikolaj Izdebski
Modified: 2013-11-10 02:24 EST (History)
2 users (show)

See Also:
Fixed In Version: jersey-1.17.1-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:24:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (2.32 KB, patch)
2013-10-15 06:56 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Mikolaj Izdebski 2013-10-15 06:47:01 EDT
Description of problem:
Package jersey fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
1.17.1-5

Steps to Reproduce:
1. rpmbuild -bb jersey.spec

Additional info:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6061388
Comment 1 Mikolaj Izdebski 2013-10-15 06:56:20 EDT
Created attachment 812424 [details]
Proposed patch
Comment 2 gil cattaneo 2013-10-15 07:11:23 EDT
thanks for reporting the problem
the problem seem caused by
<dependency>
    <groupId>com.sun</groupId>
    <artifactId>tools</artifactId>
    <version>1.7.0</version>
    <scope>system</scope>
    <systemPath>${java.home}/../lib/tools.jar</systemPath>
</dependency>
in jersey-1.17.1/contribs/wadl-resourcedoc-doclet/pom.xml
and our java tools which don't support any more this
should be solved removing scope and systemPath
Comment 3 Fedora Update System 2013-10-15 10:53:45 EDT
jersey-1.17.1-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/jersey-1.17.1-7.fc20
Comment 4 Fedora Update System 2013-10-17 16:19:50 EDT
Package jersey-1.17.1-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jersey-1.17.1-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19125/jersey-1.17.1-7.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-10 02:24:45 EST
jersey-1.17.1-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.