This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019271 - Problems connecting to eduroam (PEAP/MSCHAPv2) wireless network (Regression)
Problems connecting to eduroam (PEAP/MSCHAPv2) wireless network (Regression)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon-control-center (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 07:53 EDT by oliver
Modified: 2014-01-07 06:46 EST (History)
2 users (show)

See Also:
Fixed In Version: cinnamon-control-center-2.0.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 23:32:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description oliver 2013-10-15 07:53:23 EDT
Description of problem:
After a recent cinnmon control center update, cinnamon fails to reliable connect to a PEAP/MSCHAPv2 secured wireless network: it forgets the network password and also fails to properly handle the situation when the password is forgotten


Version-Release number of selected component (if applicable):
cinnamon-control-center-1.9.1-1.fc19

How reproducible:
Always

Steps to Reproduce:
1. Start with properly configured and working eduroam (PEAP/MSCHAPv2) wireless network 
2. Disconnect network
3. Try to re-connect network

Actual results:
1. Reconnection fails
2. When clicking on network settings, wireless hotspot is configured on, although it had not been configured before
3. When switching the wireless hotspot off, the cinnamon settings deamon crashes, the abrt tool links to the following bug report which is hidden:
https://bugzilla.redhat.com/show_bug.cgi?id=1018129
4. Connection can be restored by
a) Connecting to another unsecured network
b) Open "Network Settings", this works now
c) Click through to the configuration of the eduroam network, find that all proper settings are there, but password has been forgotten
d) Reenter password
e) Click through to the settings of the unsecured network and "Forget Network Settings"
f) Now system will properly connect to eduroam network
g) Upon first disconnect, the dance will begin from the start, i.e., the password setting is forgotten


Additional info:
It is necessary to explicitly forget the unsecured network, not just disconnect from it, because network manager (or whatever the underlying service) appears to have a relatively short timeout and eduroam is slow in authenticating, so when the unsecured network is not forgotten, network manager will reconnect to it before the eduroam authentication has completed.  This appears to be an independent bug (or misfeature).  If confirmed that this is due to network manager, I can file a bug against network manager.
Comment 1 oliver 2013-10-15 07:56:58 EDT
The option to enter the password on each connect also does not work any more in cinnamon, although it used to work.
Comment 2 oliver 2013-10-17 10:54:18 EDT
Problem persists after upgrade to cinnamon-control-center-2.0.2-1.fc19, except that the crash reported in point 3 under Actual Results appears fixed.
Comment 3 Fedora Update System 2013-10-17 12:42:39 EDT
cinnamon-screensaver-2.0.0-2.fc20, cinnamon-settings-daemon-2.0.1-2.fc20, cinnamon-2.0.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cinnamon-2.0.2-2.fc20,cinnamon-settings-daemon-2.0.1-2.fc20,cinnamon-screensaver-2.0.0-2.fc20
Comment 4 Fedora Update System 2013-10-17 12:43:28 EDT
cinnamon-screensaver-2.0.0-2.fc19, cinnamon-settings-daemon-2.0.1-2.fc19, cinnamon-2.0.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-2.0.2-2.fc19,cinnamon-settings-daemon-2.0.1-2.fc19,cinnamon-screensaver-2.0.0-2.fc19
Comment 5 Fedora Update System 2013-10-17 16:20:37 EDT
Package cinnamon-screensaver-2.0.0-2.fc20, cinnamon-settings-daemon-2.0.1-2.fc20, cinnamon-2.0.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-screensaver-2.0.0-2.fc20 cinnamon-settings-daemon-2.0.1-2.fc20 cinnamon-2.0.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19128/cinnamon-2.0.2-2.fc20,cinnamon-settings-daemon-2.0.1-2.fc20,cinnamon-screensaver-2.0.0-2.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-10-18 08:59:37 EDT
cinnamon-control-center-2.0.3-1.fc19, cinnamon-2.0.2-3.fc19, cinnamon-screensaver-2.0.0-2.fc19, cinnamon-settings-daemon-2.0.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-control-center-2.0.3-1.fc19,cinnamon-2.0.2-3.fc19,cinnamon-settings-daemon-2.0.1-2.fc19,cinnamon-screensaver-2.0.0-2.fc19
Comment 7 Fedora Update System 2013-10-18 20:13:23 EDT
Package cinnamon-control-center-2.0.3-1.fc20, muffin-2.0.2-1.fc20, nemo-2.0.1-1.fc20, cinnamon-2.0.3-1.fc20, cinnamon-screensaver-2.0.1-1.fc20, cinnamon-settings-daemon-2.0.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-control-center-2.0.3-1.fc20 muffin-2.0.2-1.fc20 nemo-2.0.1-1.fc20 cinnamon-2.0.3-1.fc20 cinnamon-screensaver-2.0.1-1.fc20 cinnamon-settings-daemon-2.0.3-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19128/nemo-2.0.1-1.fc20,muffin-2.0.2-1.fc20,cinnamon-control-center-2.0.3-1.fc20,cinnamon-2.0.3-1.fc20,cinnamon-screensaver-2.0.1-1.fc20,cinnamon-settings-daemon-2.0.3-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-22 23:32:05 EDT
cinnamon-control-center-2.0.3-1.fc19, muffin-2.0.2-1.fc19, nemo-2.0.1-1.fc19, cinnamon-2.0.3-1.fc19, cinnamon-screensaver-2.0.1-1.fc19, cinnamon-settings-daemon-2.0.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 oliver 2013-11-01 16:49:07 EDT
Please reopen bug.  I tested with latest updates cinnamon-control-center-2.0.3-1.fc19, cinnamon-2.0.6-1.fc19, cinnamon-settings-daemon-2.0.5-1.fc19. (Note: it appears to take at least a week before the updates announced in the mail from bugzilla can are found by yum even with --enablerepo=updates-testing - this makes it almost impossible to test before the bug is closed), and the issue is only partially resolved.

What works: no more funny behavior of network manager switching to hotspot functionality, no related crashes any more.

What does not work: Network Settings still forgets the password for the PEAP/MSCHAPv2 authentication after each connect.  The option "Ask for this password every time" also does not work.  

So the only way to connect is still to click through to the Wifi Security dialog for the network every time before connecting, and reenter the password there.
Comment 10 leigh scott 2013-11-01 18:23:01 EDT
(In reply to oliver from comment #9)
> Please reopen bug. 

It would be better if you filed the remaining issue upstream directly as this is beyond my scope as a package maintainer.

https://github.com/linuxmint/cinnamon-control-center


Or would you prefer me to change the bug status to "CAN'T FIX"?

> What does not work: Network Settings still forgets the password for the
> PEAP/MSCHAPv2 authentication after each connect.  The option "Ask for this
> password every time" also does not work.  
> 
> So the only way to connect is still to click through to the Wifi Security
> dialog for the network every time before connecting, and reenter the
> password there.
Comment 11 oliver 2013-11-02 05:48:12 EDT
I will file upstream if you are reasonably sure that it's an upstream bug and not due to some Fedora specific issue, maybe some nasty interaction with stock Gnome components... just let me know.
Comment 12 leigh scott 2013-11-02 06:26:07 EDT
(In reply to oliver from comment #11)
> I will file upstream if you are reasonably sure that it's an upstream bug
> and not due to some Fedora specific issue, maybe some nasty interaction with
> stock Gnome components... just let me know.

I'm reasonably sure that this issue is inherited from gnome-control-center-3.6 but haven't been able to find a commit to fix it.
Comment 13 oliver 2013-11-02 09:29:36 EDT
Filed upstream as

https://github.com/linuxmint/cinnamon-control-center/issues/45
Comment 14 Fedora Update System 2013-11-10 02:50:10 EST
cinnamon-control-center-2.0.3-1.fc20, muffin-2.0.2-1.fc20, nemo-2.0.1-1.fc20, cinnamon-2.0.3-1.fc20, cinnamon-screensaver-2.0.1-1.fc20, cinnamon-settings-daemon-2.0.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 oliver 2014-01-07 06:46:22 EST
This problem is not fixed.

Actually, it got worse: After system update to F20, the situation got worse: Whenever there is an eduroam network present and wireless is enabled, there is an endless stream of notifications "cannot connect to wireless network" unless one actually goes to Network Settings and enters the password.  This is now also more difficult as network manager seems to cycle through all unsecured networks and the order in the network settings list constantly changes, so that one has to be lucky to hit the eduroam configuration button...

Is there any chance this will be fixed?  There is still at least one more cinnamon regression (all windows move to secondary screen after resume when two screens are attached) which was also introduced around the time that cinnamon decided it had to roll its own control center about half a year ago, and things don't seem to improve.

I don't want to sound negative as I am very grateful for cinnamon as a fix to the Gnome usability problems, but just a thought: would it be possible to use the real Gnome infrastructure for system configuration on Fedora, rather than cinnamon's own fork? (Apparently, this has been the situation all the way up to last summer, and everything used to work well.)  I see little point trying to duplicate the QA that takes place for Fedora's default system configuration.  The current situation shows that it's not a sustainable state of affairs: One has to choose between poor UI (with Gnome) and poor integration (with cinnamon), which is a situation that really really sucks...

Note You need to log in before you can comment on or make changes to this bug.