This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019286 - moving dashboard widgets causes Red Alert (exception) on next login
moving dashboard widgets causes Red Alert (exception) on next login
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 08:13 EDT by Garik Khachikyan
Modified: 2015-01-04 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (32.72 KB, image/png)
2013-10-15 08:13 EDT, Garik Khachikyan
no flags Details
katello-debug.logs (141.89 KB, application/gzip)
2013-10-15 08:13 EDT, Garik Khachikyan
no flags Details
foreman-debug.log (57.56 KB, application/x-xz)
2013-10-15 08:14 EDT, Garik Khachikyan
no flags Details
err_repro_mdp2box (184.10 KB, image/png)
2013-10-17 17:45 EDT, manjiri tapaswi
no flags Details
err_repro_kt_nightly (153.25 KB, image/png)
2013-10-17 17:48 EDT, manjiri tapaswi
no flags Details

  None (edit)
Description Garik Khachikyan 2013-10-15 08:13:16 EDT
Created attachment 812472 [details]
screenshot

Description of problem:
doing rearrange of dashboard widgets (e.g. moving "Promotions Overview" to the bottom-right) causes red alert in each login of the user (see screenshot)

Version-Release number of selected component (if applicable):
candlepin-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-demeter.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.6-31.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
katello-all-1.4.6-31.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-20.el6sat.noarch
katello-cli-common-1.4.3-20.el6sat.noarch
katello-common-1.4.6-31.el6sat.noarch
katello-configure-1.4.7-3.el6sat.noarch
katello-configure-foreman-1.4.7-3.el6sat.noarch
katello-configure-foreman-proxy-1.4.7-3.el6sat.noarch
katello-foreman-all-1.4.6-31.el6sat.noarch
katello-glue-candlepin-1.4.6-31.el6sat.noarch
katello-glue-elasticsearch-1.4.6-31.el6sat.noarch
katello-glue-pulp-1.4.6-31.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.3.0-0.17.beta.el6sat.noarch
python-pulp-bindings-2.3.0-0.17.beta.el6sat.noarch
python-pulp-common-2.3.0-0.17.beta.el6sat.noarch
python-pulp-puppet-common-2.3.0-0.17.beta.el6sat.noarch
python-pulp-rpm-common-2.3.0-0.17.beta.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.14-5.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.7-2.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-katello-0.0.22-2.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. see above
2.
3.

Actual results:
undefined method `owner_info' for nil:NilClass (NoMethodError)
Click here for more details.

Expected results:
no exception (should behave the same way as if none of them were moved :)

Additional info:
see the screenshot + logs attached
Comment 1 Garik Khachikyan 2013-10-15 08:13:56 EDT
Created attachment 812473 [details]
katello-debug.logs
Comment 2 Garik Khachikyan 2013-10-15 08:14:26 EDT
Created attachment 812474 [details]
foreman-debug.log
Comment 4 manjiri tapaswi 2013-10-17 17:45:06 EDT
Created attachment 813559 [details]
err_repro_mdp2box

Tested on mmccune's mdp2 box 
(https://intel-s3ea2-04.rhts.eng.bos.redhat.com/katello/dashboard#/!=)
Comment 5 manjiri tapaswi 2013-10-17 17:48:25 EDT
Created attachment 813561 [details]
err_repro_kt_nightly

Tested on katello nightly
Comment 6 manjiri tapaswi 2013-10-17 17:50:03 EDT
Attempted to reproduce - No errors/notifications/alerts - Attached screenshots

Steps:
1. Moved the dashboard widgets including 'Promotions Overview' around and to the bottom right corner
2. Logged out and logged-in few times
Comment 7 Garik Khachikyan 2013-10-18 03:34:18 EDT
Please - I strongly recommend to test also in the product the original issue was found (once developers will put the issue to on_qa).
Comment 8 Mike McCune 2013-10-23 19:23:46 EDT
Garik, I did have her test in MDP2, see Comment 4

This bug actually looks like:

https://bugzilla.redhat.com/show_bug.cgi?id=1021145

same error condition which actually has nothing todo with dragging the dashboard widgets around.

I re-tested this with SNAP7 and couldn't reproduce the error either

I'd vote we close this as a dupe or just re-test with the latest snap since I can't see any errors on my SNAP7 instance:

https://dhcp-8-30-75.lab.eng.rdu2.redhat.com/katello/dashboard#/!=

if you have a system where this is occurring please let us know, happy to dig into it.
Comment 9 Sachin Ghai 2013-10-24 04:27:00 EDT
Verified with MDP2 snap7. The reported issue is not reproducible. 

katello-all-1.4.6-47.el6sat.noarch
katello-cli-1.4.3-27.el6sat.noarch
katello-glue-pulp-1.4.6-47.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-glue-candlepin-1.4.6-47.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-foreman-all-1.4.6-47.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-configure-1.4.7-7.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-47.el6sat.noarch
katello-1.4.6-47.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-common-1.4.6-47.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-common-1.4.3-27.el6sat.noarch

I moved different dashboards to different positions like bottom right, top right and specifically to 'Promotions overview'. And later tried to logout with current user and re-login several times. The issue is no longer reproducible neither with admin nor with any other user.

Moving this to verified.
Comment 10 Bryan Kearney 2014-04-24 13:09:07 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 11 Bryan Kearney 2014-04-24 13:10:42 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.