Bug 101930 - missing buildrequires
missing buildrequires
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: librsvg2 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 110659 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 05:25 EDT by Michael Redinger
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 15:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2003-08-08 05:25:16 EDT
The nautilus-2.2.4-4.E.src.rpm is missing a BuildRequires for libgsf-devel.
If it is not available, configure fails:

checking for pkg-config... /usr/bin/pkg-config
checking for    esound >= 0.2.27        bonobo-activation-2.0 >= 2.1.0  eel-2.0
>= 2.2.3        glib-2.0 >= 2   gnome-desktop-2.0 >= 2.1.0      gnome-vfs-2.0 >=
2.1.5  ORBit-2.0 >= 2.4.0      pango >= 1.1.2  gtk+-2.0 >= 2.1.1      
libart-2.0 >= 2.3.10    libbonobo-2.0 >= 2.1.0  libbonoboui-2.0 >= 2.0.0       
libgnome-2.0 >= 2.1.1   libgnomeui-2.0 >= 2.1.1         librsvg-2.0 >= 2.0.1   
libxml-2.0 >= 2.4.7... Package libgsf-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgsf-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libgsf-1', required by 'librsvg', not found

configure: error: Library requirements (        esound >= 0.2.27       
bonobo-activation-2.0 >= 2.1.0  eel-2.0 >= 2.2.3        glib-2.0 >= 2  
gnome-desktop-2.0 >= 2.1.0      gnome-vfs-2.0 >= 2.1.5  ORBit-2.0 >= 2.4.0     
pango >= 1.1.2  gtk+-2.0 >= 2.1.1       libart-2.0 >= 2.3.10    libbonobo-2.0 >=
2.1.0  libbonoboui-2.0 >= 2.0.0        libgnome-2.0 >= 2.1.1   libgnomeui-2.0 >=
2.1.1         librsvg-2.0 >= 2.0.1    libxml-2.0 >= 2.4.7) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.35575 (%build)
Comment 1 Alexander Larsson 2003-08-08 06:10:15 EDT
This is really a librsvg2 bug.
Comment 2 Matthias Clasen 2004-05-13 16:41:19 EDT
*** Bug 110659 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Clasen 2004-06-23 15:13:38 EDT
This was apparently fixed in 2.4.0-3

Note You need to log in before you can comment on or make changes to this bug.