Bug 101937 - To UTF-8 or not :)
Summary: To UTF-8 or not :)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: beta3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-08 11:56 UTC by Richard Allen
Modified: 2014-03-17 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 16:29:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Allen 2003-08-08 11:56:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030702

Description of problem:
By default, all port RH 8 machines are using UTF-8.  Here in Iceland we end up
with LANG set to is_IS.UTF-8 in /etc/sysconfig/i18n.
This is all fine and dandy, but when we log into other machines (that are not
using UTF-8) from our RedHat boxes or vice versa, things get messed up.   This
is particulary bad for Icelandic because we have 20 special symbols (counting
both cases).  This means most people change the system wide LANG to is_IS (thus
not using UTF-8 but ISO-8859-1).
This however opens up a whole new set of problems because all the .po files are
in UTF-8 format.  One of the most apparent problems is while the machine is
booting or shutting down (initscripts).  If LANG is is_IS the Icelandic chars in
the translations dont print right.
Cant we have two versions of the compiled .po files ?  One in UTF-8 and another
in ISO-8859-X ?   System would go "Im using an UTF-8 locale, so Im going to use
the UTF-8 .po files"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See the description
    

Additional info:

Comment 1 Bill Nottingham 2003-08-08 16:29:21 UTC
No, utf-8 is the supported locale.

Comment 2 Richard Allen 2003-08-08 18:28:15 UTC
then why ship the ISO-8859-X locales at all ?



Note You need to log in before you can comment on or make changes to this bug.