Bug 1019380 - Trying to create the already existed example repository after the restart of BPMS
Trying to create the already existed example repository after the restart of ...
Status: CLOSED DUPLICATE of bug 1016578
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ---
: 6.0.0
Assigned To: Maciej Swiderski
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 11:16 EDT by Ivo Bek
Modified: 2013-10-21 06:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 06:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the stacktrace with FileAlreadyExistsException from the server log (7.57 KB, text/plain)
2013-10-15 11:16 EDT, Ivo Bek
no flags Details

  None (edit)
Description Ivo Bek 2013-10-15 11:16:17 EDT
Created attachment 812584 [details]
the stacktrace with FileAlreadyExistsException from the server log

Description of problem:

After a restart I see the following exception during the initialization of business central.

17:12:40,489 ERROR [org.jbpm.console.ng.bd.backend.server.AdministrationServiceImpl] (MSC service thread 1-1) Unable to bootstrap project org.kie.example:example-project:1.0.0-SNAPSHOT in repository example-repository: org.kie.commons.java.nio.file.FileAlreadyExistsException
	at org.kie.commons.java.nio.fs.jgit.JGitFileSystemProvider.createDirectory(JGitFileSystemProvider.java:839) [kie-nio2-jgit-6.0.0-redhat-5.jar:6.0.0-redhat-5]
	at org.kie.commons.java.nio.file.Files.createDirectory(Files.java:259) [kie-nio2-api-6.0.0-redhat-5.jar:6.0.0-redhat-5]
	at org.kie.commons.io.impl.IOServiceDotFileImpl.internalCreateDirectory(IOServiceDotFileImpl.java:336) [kie-commons-io-6.0.0-redhat-5.jar:6.0.0-redhat-5]
	at org.kie.commons.io.impl.IOServiceDotFileImpl.createDirectory(IOServiceDotFileImpl.java:117) [kie-commons-io-6.0.0-redhat-5.jar:6.0.0-redhat-5]
	at org.guvnor.common.services.project.backend.server.KModuleServiceImpl.setUpKModuleStructure(KModuleServiceImpl.java:70) [guvnor-project-backend-6.0.0-redhat-5.jar:6.0.0-redhat-5]
	at org.guvnor.common.services.project.backend.server.KModuleServiceImpl$Proxy$_$$_WeldClientProxy.setUpKModuleStructure(KModuleServiceImpl$Proxy$_$$_WeldClientProxy.java) [guvnor-project-backend-6.0.0-redhat-5.jar:6.0.0-redhat-5]

full stacktrace is attached.

How reproducible:


Steps to Reproduce:
1. install BPMS 6.0.0.ER4 with EAP 6.1.0
2. start BPMS for the first time
3. restart BPMS - stop the running instance, and start it again
4. see "Unable to bootstrap project org.kie.example:example-project:1.0.0-SNAPSHOT in repository example-repository: org.kie.commons.java.nio.file.FileAlreadyExistsException"
Comment 1 Maciej Swiderski 2013-10-21 06:46:51 EDT

*** This bug has been marked as a duplicate of bug 1016578 ***

Note You need to log in before you can comment on or make changes to this bug.