Bug 1019534 - mate-desktop background fails in workspaces
mate-desktop background fails in workspaces
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-desktop (Show other bugs)
19
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 21:54 EDT by jonathan baron
Modified: 2013-10-19 05:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-desktop-1.6.2-0.5.git81c245b.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-19 05:08:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonathan baron 2013-10-15 21:54:38 EDT
Description of problem:

When I switch to a workspace with nothing in it, instead of getting the default background I get an image of the last workspace in which I opened anything, e.g., a terminal window, but it is unusable, just an image of it. I can open something else in the workspace, however.

Version-Release number of selected component (if applicable)

mate-desktop-libs-1.6.2-0.4.git81c245b.fc19.x86_64
mate-desktop-1.6.2-0.4.git81c245b.fc19.x86_64

How reproducible:

This happens on both x86-64 and i686. All the time. 4 different machines.

Steps to Reproduce:
1. Update mate-desktop(-libs)
2. Do anything, so long as you use multiple workspaces (the reason
I gave up Gnome for Mate).

Additional info:

yum downgrade mate-desktop mate-desktop-libs
fixed the problem. I'm not sure which is crucial.
Comment 1 Wolfgang Ulbrich 2013-10-16 04:48:58 EDT
mate-desktop-1.6.2-0.5 should fix the issue.
Comment 2 Fedora Update System 2013-10-16 04:50:52 EDT
mate-desktop-1.6.2-0.5.git81c245b.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-desktop-1.6.2-0.5.git81c245b.fc18
Comment 3 Fedora Update System 2013-10-16 04:51:02 EDT
mate-desktop-1.6.2-0.5.git81c245b.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-desktop-1.6.2-0.5.git81c245b.fc19
Comment 4 Fedora Update System 2013-10-18 15:46:57 EDT
Package mate-desktop-1.6.2-0.5.git81c245b.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-desktop-1.6.2-0.5.git81c245b.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19308/mate-desktop-1.6.2-0.5.git81c245b.fc19
then log in and leave karma (feedback).
Comment 5 jonathan baron 2013-10-18 16:41:38 EDT
(In reply to Fedora Update System from comment #4)
> Package mate-desktop-1.6.2-0.5.git81c245b.fc19:
> * should fix your issue,
> * was pushed to the Fedora 19 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing
> mate-desktop-1.6.2-0.5.git81c245b.fc19'
> as soon as you are able to.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2013-19308/mate-desktop-1.6.2-
> 0.5.git81c245b.fc19
> then log in and leave karma (feedback).

To get this to work, I had to do this:
yum update --enablerepo=updates-testing mate-desktop\*
which gave me both mate-desktop and mate-desktop-libs

It did not work the first way because I needed -libs. I then downloaded the rpm from the git repository and that didn't work either. But this worked.

However, after logging out and logging in, part of the same problem is present. I do not get my preferred background. Instead, I get a black screen.

I'm going to try to revert.
Comment 6 Wolfgang Ulbrich 2013-10-18 17:09:17 EDT
mate-desktop-1.6.2-0.5.git81c245b fix this.
Please check gsettings.
[rave@mother ~]$ gsettings get org.mate.background draw-background
true
[rave@mother ~]$ gsettings get org.mate.background background-fade
true
[rave@mother ~]$ gsettings get org.mate.SettingsDaemon.plugins.background active
true
Comment 7 jonathan baron 2013-10-18 17:44:45 EDT
(In reply to Wolfgang Ulbrich from comment #6)
> mate-desktop-1.6.2-0.5.git81c245b fix this.
> Please check gsettings.
> [rave@mother ~]$ gsettings get org.mate.background draw-background
> true
> [rave@mother ~]$ gsettings get org.mate.background background-fade
> true
> [rave@mother ~]$ gsettings get org.mate.SettingsDaemon.plugins.background
> active
> true

All are true. I checked this after downgrade, but they should not be changed, right?
Comment 8 Wolfgang Ulbrich 2013-10-18 18:00:32 EDT
Yes, those are the correct values.
We did a gsettings.override for 1.6.2-0.4.git81c245b which set it to false for fixing another bug.
But we forgot that ex-gnome user prefer to disable caja gsettings key 'show-desktop-icons' which also disable draw background by caja ;)
In result neither caja and mate-settings-daemon don't draw the background.
With mate-desktop-1.6.2-0.5.git81c245b i revert the override.
So check if those keys are 'true' with mate-desktop-1.6.2-0.5.git81c245b .
Comment 9 jonathan baron 2013-10-18 19:10:00 EDT
(In reply to Wolfgang Ulbrich from comment #8)
> Yes, those are the correct values.
> We did a gsettings.override for 1.6.2-0.4.git81c245b which set it to false
> for fixing another bug.
> But we forgot that ex-gnome user prefer to disable caja gsettings key
> 'show-desktop-icons' which also disable draw background by caja ;)
> In result neither caja and mate-settings-daemon don't draw the background.
> With mate-desktop-1.6.2-0.5.git81c245b i revert the override.
> So check if those keys are 'true' with mate-desktop-1.6.2-0.5.git81c245b .

OK. I again did 
yum update --enablerepo=updates-testing mate-desktop\*
and logged out and logged in. This time

baron@barber ~ > gsettings get org.mate.background draw-background
true
baron@barber ~ > gsettings get org.mate.background background-fade
false
baron@barber ~ > gsettings get org.mate.SettingsDaemon.plugins.background active
false

But when I set the last two to true, it worked properly. So I think there is still a problem. Users should not have to do this.

Indeed, I had disabled the icons, which look like -- well, how to say it? -- unpleasant smudges on what is otherwise a nice picture.
Comment 10 Wolfgang Ulbrich 2013-10-19 04:01:10 EDT
Can you post with mate-desktop-1.6.2-0.5.git81c245b
[rave@mother ~]$ cat /usr/share/glib-2.0/schemas/mate-fedora.gschema.override 
[org.mate.background]
picture-filename='/usr/share/backgrounds/default.png'

[org.mate.session]
required-components-list=[ 'windowmanager', 'panel' ]

[org.mate.session.required-components]
filemanager=''

[org.mate.font-rendering]
antialiasing='rgba'
hinting='slight'

Btw, it views hopefully like this.
Comment 11 Fedora Update System 2013-10-19 05:08:38 EDT
mate-desktop-1.6.2-0.5.git81c245b.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-10-19 05:09:34 EDT
mate-desktop-1.6.2-0.5.git81c245b.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.