Bug 1019536 - iscsi root should support bridged and nonbridged network
iscsi root should support bridged and nonbridged network
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
: 1017117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 22:25 EDT by Joey Boggs
Modified: 2014-03-21 06:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-21 06:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joey Boggs 2013-10-15 22:25:56 EDT
Description of problem:
if iscsi root is installed and configured without a bridge, the network will appear to not be configured. The ip configuration in the grub boot args should match the same type of configuration used during the networking auto install.

Steps to Reproduce:
1. install as iscsi root
2. login as admin
3. check network status in tui

By default iscsi assumes a bridged connection, if network_layout karg was set to bridged it would be fine, unbridged will appear to be unconfigured.
Comment 2 haiyang,dong 2013-10-16 01:17:07 EDT
Seems this bug was duplicated of Bug 1017117
Comment 3 Joey Boggs 2013-10-16 08:32:38 EDT
*** Bug 1017117 has been marked as a duplicate of this bug. ***
Comment 5 haiyang,dong 2013-11-05 05:28:34 EST
Test version:
rhev-hypervisor6-6.5-20131031.1
ovirt-node-3.0.1-7.el6.noarch

Tested as follows:
1. install as iscsi root with bridged and nonbridged
(a) BOOTIF=eth0 storage_init=/dev/sda,/dev/sdb iscsi_init=/dev/sdb iscsi_target_name=iqn.2013-01.com:hadong iscsi_install 
iscsi_server=10.66.11.127:3260 firstboot
(b) BOOTIF=eth0 storage_init=/dev/sda,/dev/sdb iscsi_init=/dev/sdb iscsi_target_name=iqn.2013-01.com:hadong iscsi_install 
iscsi_server=10.66.11.127:3260 firstboot network_layout=bridged
2. login as admin
3. check network status in tui

After auto install success, then login rhev-h and check that ipv4 address in state page,and nics was shown configured in network page.
Now iscsi root has supported bridged and nonbridged network,
so this bug has been fixed, i will verify it after it's status changed into "ON_QA"
Comment 6 Fabian Deutsch 2014-03-21 06:11:37 EDT
This bug wasn't in the erratum but is fixed, so closing this.

Please reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.