Bug 101965 - up2date won't install kernel-unsupported rpm update
up2date won't install kernel-unsupported rpm update
Status: CLOSED DUPLICATE of bug 101963
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 09:27 EDT by Bernd Bartmann
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2003-08-08 09:27:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030709

Description of problem:
up2date thinks that kernel-unsupported is already installed on my system:

[root@sohanetpc5 root]# up2date --show-available
kernel-BOOT-2.4.21-1.1931.2.382.ent
kernel-bigmem-2.4.21-1.1931.2.382.ent
kernel-bigmem-unsupported-2.4.21-1.1931.2.382.ent
kernel-smp-2.4.21-1.1931.2.382.ent
kernel-smp-unsupported-2.4.21-1.1931.2.382.ent
kernel-unsupported-2.4.21-1.1931.2.382.ent

[root@sohanetpc5 root]# up2date --nosig --install kernel-unsupported
 
Fetching package list for channel: rhel3-beta1-as-i386...
########################################
 
Fetching package list for channel: rhel3-beta1-as-i386-updates...
########################################
 
Fetching Obsoletes list for channel: rhel3-beta1-as-i386...
########################################
 
Fetching Obsoletes list for channel: rhel3-beta1-as-i386-updates...
########################################
 
Fetching rpm headers...
########################################
 
The following packages you requested are already updated:
kernel-unsupported
[root@sohanetpc5 root]# rpm -qa|grep kernel
kernel-2.4.21-1.1931.2.349.2.2.ent
kernel-pcmcia-cs-3.1.31-13
kernel-source-2.4.21-1.1931.2.382.ent
kernel-2.4.21-1.1931.2.377.ent
kernel-2.4.21-1.1931.2.382.ent
kernel-utils-2.4-8.33


up2date --force ... solves the problem

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try up2date on kernel-unsupported rpm
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2003-08-08 12:59:24 EDT

*** This bug has been marked as a duplicate of 101963 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.