Bug 1019662 - AttributeError: 'NoneType' object has no attribute 'get_child'
AttributeError: 'NoneType' object has no attribute 'get_child'
Status: CLOSED DUPLICATE of bug 962537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:cc32d1e193efdce086ea8f7c110...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 04:28 EDT by Cristian Ciupitu
Modified: 2014-01-02 15:16 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:16:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (566.55 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: anaconda.log (45.45 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: environ (525 bytes, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: lsblk_output (2.13 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: nmcli_dev_list (4.33 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: os_info (291 bytes, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: program.log (86.48 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: storage.log (383.37 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: ifcfg.log (1.29 KB, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details
File: packaging.log (128 bytes, text/plain)
2013-10-16 04:28 EDT, Cristian Ciupitu
no flags Details

  None (edit)
Description Cristian Ciupitu 2013-10-16 04:28:02 EDT
Description of problem:
Did some automatic partitioning then some manual partitioning.

Version-Release number of selected component:
anaconda-20.21-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.21-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1063, in _update_selectors
    page = self._accordion._find_by_title(self.translated_new_install_name).get_child()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1403, in _save_right_side
    self._update_selectors()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2401, in _save_current_selector
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2412, in on_selector_clicked
    self._save_current_selector()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 216, in _onSelectorClicked
    cb(selector)
AttributeError: 'NoneType' object has no attribute 'get_child'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=testday-2013-10-10 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.2-301.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

Potential duplicate: bug 967846
Comment 1 Cristian Ciupitu 2013-10-16 04:28:11 EDT
Created attachment 812812 [details]
File: anaconda-tb
Comment 2 Cristian Ciupitu 2013-10-16 04:28:16 EDT
Created attachment 812813 [details]
File: anaconda.log
Comment 3 Cristian Ciupitu 2013-10-16 04:28:20 EDT
Created attachment 812814 [details]
File: environ
Comment 4 Cristian Ciupitu 2013-10-16 04:28:24 EDT
Created attachment 812815 [details]
File: lsblk_output
Comment 5 Cristian Ciupitu 2013-10-16 04:28:28 EDT
Created attachment 812816 [details]
File: nmcli_dev_list
Comment 6 Cristian Ciupitu 2013-10-16 04:28:34 EDT
Created attachment 812817 [details]
File: os_info
Comment 7 Cristian Ciupitu 2013-10-16 04:28:38 EDT
Created attachment 812818 [details]
File: program.log
Comment 8 Cristian Ciupitu 2013-10-16 04:28:43 EDT
Created attachment 812819 [details]
File: storage.log
Comment 9 Cristian Ciupitu 2013-10-16 04:28:48 EDT
Created attachment 812820 [details]
File: ifcfg.log
Comment 10 Cristian Ciupitu 2013-10-16 04:28:51 EDT
Created attachment 812821 [details]
File: packaging.log
Comment 11 Lukas Brabec 2013-11-07 07:51:10 EST
Trired to review my disk partitioning (probably similar to https://bugzilla.redhat.com/show_bug.cgi?id=978298).

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
package:        anaconda-20.25.6-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'get_child'
release:        Cannot get release name.
version:        20-Beta
Comment 12 David Shea 2014-01-02 15:16:25 EST

*** This bug has been marked as a duplicate of bug 962537 ***

Note You need to log in before you can comment on or make changes to this bug.